
Introduction
This manual contains complete documentation for FabFilter Pro-C in printer-friendly format. All information in this manual is also
accessible via the Help button in FabFilter Pro-C's user interface.
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About FabFilter Pro-C
There is one signal-processing tool that is almost impossible to do without in any form of audio recording or post-production:
compression. Compression is available in a wide variety of different formats, flavors, designs and degrees of quirkiness.

FabFilter Pro-C is not just a good sounding compressor. FabFilter Pro-C is an unusual stereo compressor with all the tricks up its
sleeve that you will ever need. With added options like Mid/Side compression, side-chaining with built-in filters or even with
external sources, it can work in any way you'll ever need. Whether for mastering or mixing, Pro-C will do the job with lots of style.

Key features include various program dependent compression characteristics, very high quality sound with 64-bit internal processing
and zero latency, flexible routing and side chain possibilities, and an innovative interface. Apart from its beautiful sound and
character, FabFilter Pro-C also offers amazingly flexible routing options for both mono, stereo, and mid/side processing.

FabFilter Pro-C is available in VST, VST3, AU (Audio Units), AAX Native and AudioSuite formats (all both 64-bit and 32-bit), as well
as RTAS (32-bit only), for Mac OS X and Windows.

Windows requirements:

32-bit: Windows 8, 7, Vista or XP

64-bit: Windows 8, 7 or Vista (x64)

VST 2/3 host or Pro Tools

Mac OS X requirements:

32-bit: OS X 10.5 or higher

64-bit: OS X 10.6 or higher

AU or VST 2/3 host or Pro Tools

Intel processor

Next: Quick start

See Also
Using FabFilter Pro-C
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Quick start
The installer will copy the FabFilter Pro-C plug-in into the common VST, VST 3, AU (OS X only) and Pro Tools plug-in folders on your
computer. On Mac OS X, the global plug-in folders in /Library/Audio/Plug-Ins are used.

In most cases, your host will then recognize the plugin automatically. However, if the instructions below do not work, see Manual
installation instead.

Cubase
Choose an empty insert slot, for example in the Mixer, and select FabFilter Pro-C from the menu that appears. To use the
MIDI features in Pro-C, create a new MIDI track and set its output to the Pro-C instance you have just created. (The VST 3
version of Pro-C can be found in the Dynamics section.)

Logic Pro
Choose an empty insert slot on one of your audio tracks, instrument tracks or buses and select FabFilter Pro-C from the pop-
up menu. You will find FabFilter Pro-C in the Audio Units -> FabFilter section (named FF Pro-C).

Ableton Live
In Session view, select the track you would like to place FabFilter Pro-C on, for example by clicking the track name. At the left
top of Ableton Live's interface, click on the Plug-in Device Browser icon (third icon from the top). From the plug-ins list,
double-click FabFilter/FabFilter Pro-C, or drag it onto the track.

Pro Tools
Choose an empty insert slot on one of your audio tracks, instrument tracks or buses and select FabFilter Pro-C from the pop-
up menu in the Dynamics section.

To begin, make sure attack and release are both zero. Put the ratio in a gentle 4:1 setting and bring down the threshold to make
compression audible. Play with those parameters until you have the desired effect. Have fun!

Next: FabFilter Pro-C overview

See Also
Compressor Basics
Overview
VST plug-in versions
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Compressor basics
The compressor was invented to control the gain on a recorded track. In the early days this was done by hand. The best way to
even out the level of a recorded track is to "ride" the fader manually. When the signal gets too loud, the engineer brings it down.
This involved following a score (or working from memory) and making level changes in anticipation of the peaks in the music. And
so the compressor was invented to do this automatically. It takes less attention and it can respond to faster changes.

But then came, yes indeed, The Beatles! And they started using that compressor to change sound in a new way. Sly Stone was also
very pleased with heavily compressed sounds. Since those days compression is everywhere. Compression can be applied to any
signal that varies too much in level, on separate tracks or complete mixes. Or can be used as a way to create a certain sound
famously used on Daft Punk albums.

Nowadays it is used extensively in audio recording, production work, noise reduction, and live performance applications.
Compression can easily be overdone though, and this leads to music with little or no dynamics. This also created the so-called (not
so cool) "loudness war" to which FabFilter Pro-C does not intend to contribute. (More on that in this Wikipedia article .)

So how does it work?

On an analogue mixer a fader would be a "manually controlled amplifier", but since it is here done automatically that component is
shown as DCA (digitally controlled amplifier). To make that fader "go down", the signal is sent to a so-called "side chain" which
consists of a level detector and gain control. So the gain control is the actual compressor. It will control the level in time using the
attack and release times of the compressor, and will change the volume based on threshold and ratio settings.

When a signal is fed to the level detector that is above the threshold, the gain controller will lower the volume (after the attack
time) with an amount based on the ratio setting. This input/output relationship is often described by a simple graph called the
transfer function. The horizontal axis corresponds to the input signal level, and the vertical axis is the output level (measured in
decibels). The line at 45 degrees corresponds to a ratio of 1 (no compression).

The compressor setting is usually stated as a ratio, such as 2:1, which means that the input level would have to increase by two
decibels to create a one decibel increase in the output and thus the effective gain reduction is 1 dB. With a 4:1 setting, the input
would need to change by 4 dB for a 1 dB change in the output level and thus the effective gain reduction is 3 dB, and so on. This
means the amount of gain reduction is determined by the ratio control in combination with the threshold. Low thresholds mean the
compression starts at a lower level, so there will be a lot of gain reduction. High ratios squash signals above the threshold harder,
also introducing a lot of gain reduction.

This picture shows what is actually happening:
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Here you can see that the compressor will lower the level of a signal above the threshold based on the ratio setting after the attack
time. When the input signal falls below the threshold again, the compressor recovers with the release time, back to the original
signal. And that's what a compressor is all about.

Last but not least:

Soft knee compression works slightly different. A soft knee brings in the compression more progressively by gradually increasing
the compression ratio as the signal level approaches the threshold level. Soft knee compression is more subtle, since the
compressor doesn't wait and then suddenly applies the full level of compression at the threshold. Therefore a soft knee is more
suitable for compressing whole mixes or gentle sounds that hover around the threshold.

Next: Advanced compressor techniques

See Also
Dynamic parameters
Time parameters
Expert mode
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Advanced compressor techniques
If you understand Compressor Basics, it is time for some more advanced use of the compressor technology. As mentioned above,
the compressor normally monitors the main input signal through a side-chain circuit, but we could send another signal to the level
detector. The most common example would be the radio DJ. While music is playing, speaking into the microphone will cause the
level of the music to drop so that it's easier to hear the DJ talking. To do this we have to insert the compressor on the music track
but send the vocal to the level detector.

This technique is called "ducking". When mixing in the studio, ducking can also be used to emphasize certain elements, such as the
kick drum. The kick could lower other tracks in the mix, increasing its "presence".

FabFilter Pro-C also provides the option to patch an EQ unit before the level detector to make the compressor respond only to
frequencies passed on by the EQ. Remember that this EQ does not effect the actual input signal but only the level detector. The
gain control then adjusts the actual input signal.
"Why?" I hear you ask... Maybe we want the compressor to ignore the low end of a drum mix when compressing that drum mix.
Then we need a high-pass filter before the level detector so the level of the low kick drum will not cause the compressor to react.

If you have more questions you could start reading this article  (the Internet has many good articles about this subject).

Just one more thing we'd like to add. When using compression there is only one thing to remember: there is no rule. Experiment
with settings and all the possibilities FabFilter Pro-C has to offer!

Next: Mid/Side introduction

See Also
Compressor basics
Dynamic parameters
Time parameters
Expert mode
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Mid/Side introduction
Mid/Side, or the representation of stereo sound as the sum and difference of the two channels. What does that mean and why
would we want that in a compressor?

The Mid/Side concept has its origin in stereo microphone techniques using two microphones (more about that here on Wikipedia )
but also gives us many options to change a stereo audio signal.

Now, if you can handle a bit of schoolboy algebra let's demonstrate how it works. To begin with, the 2-channel audio data is
described in terms of the Left (L) and Right (R) channel. From these we can get the Mid and Side channels with the following
calculation:

Mid = (L+R)/2
Side = (L-R)/2

The Mid channel is also often called "Mono" and Side "Stereo" (that's nice, the first letters are the same!). The Mid channel contains
the signal that is in the center of the stereo mix, and the Side channel contains the rest (everything that is on the sides of the mix).
By seperating them, we have the opportunity to process those signals independently.

Should we wish to return from Mid/Side format back to Left/Right, then we can recreate the Left channel by summing the Mid plus
the Side, and the Right channel by taking the Mid minus the Side, as follows:

Left = Mid + Side
Right = Mid - Side

Any conventional stereo signal can be converted to Mid/Side stereo, and back again, with no loss of information! Using the Mid and
Side channels to treat them differently gives us many creative opportunities and gives a tremendous amount of control over the
stereo spread.

So why we want to use that in a compressor? Well, there are a few basic possibilities that mastering engineers use to control the
amount of stereo spread in a track. By compressing only the Side and leave the Mid unaltered, it will sound more 'mono' without
introducing phase problems.

Alternately, if you would only compress the Mid and leave the Side unaltered, you will get a more compressed sound without
touching the stereo spread.

FabFilter Pro-C gives you both options and anything in between.

Next: Overview

See Also
Expert mode
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Overview
The interface of FabFilter Pro-C is divided in several sections. The top section controls the dynamic behavior and consists of the level
and time parameters. At the right you'll find the output section. Several displays in the left bottom corner show all dynamic
information, while the right bottom corner contains the MIDI Learn controls.

Dynamic parameters 
This section contains the parameters that control the dynamic behavior of the compressor. The input and threshold combined
with the ratio will determine how much compression is being applied. The input can be panned when Expert mode is activated.
See Dynamic Parameters.

Time parameters
The time parameters section contains the attack and release time controls. See Time parameters.

Output section
This is where the output mix and panning settings are controlled. The dry (unprocessed) signal and the output of the
compressor have their own output volume knobs allowing parallel compression. Panning can be applied when Expert mode is
activated. See Output section.

Level displays
This section contains the transfer function display, animated level display, and the peak level meters. These enable you to
very precisely monitor input and output level and the applied gain reduction for every second of sound. See Displays.

Expert parameters 
In Expert mode, this section will give you unsurpassed options to compress the audio signal. External input, stereo linked,
unlinked, mid/side compression or anything in between is possible. See Expert mode.

Undo and A/B switch
The Undo, Redo, A/B and Copy buttons at the top of the plug-in interface enable you to undo your changes and switch
between different states of the plug-in. See Undo and redo and A/B switch.

Presets
With the preset buttons, you can easily browse through the factory presets or save your own settings so you can re-use them
in other songs. See Loading presets.

MIDI learn
MIDI Learn offers the possibility to easily associate any MIDI controller with any plug-in parameter. See MIDI Learn.

Next: Knobs

See Also
Quick start
Expert mode
Compressor basics
Component routing
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Knobs
It is easy to control FabFilter Pro-C's parameters with the large round knobs. They will light up when you move the mouse cursor
around to indicate that you can adjust them. The moment you move the mouse cursor over a knob, a parameter value display will
pop up, which shows the name and the current value of the parameter.

All knobs support four ways of control:

1. Vertical mode
Click on the center area of a knob and drag up or down to rotate it. The knob reacts to the speed with which you are
dragging, so if you move the mouse slowly, you make precise adjustments.

2. Rotate mode
Grab the arrow of the knob and drag it around. By moving the mouse cursor further away from the knob while dragging it,
you can make precise adjustments.

3. Mouse wheel mode
Perhaps the easiest way to make adjustments is by using the mouse wheel when you hover over a knob. This mode works
for all the knobs and possible panning rings. (On Windows, you might need to click in the plug-in interface first to make
sure it is the active window.)

4. Text entry mode
Double-click on a knob to enter an exact value using the keyboard.

Tips

To reset a knob to its default position, hold down the Ctrl key (Windows) or Command key (Mac OS X) and click the knob
once.

To fine-tune a value when using vertical drag mode or the mouse wheel, hold down the Shift key while dragging or moving
the mouse wheel.

In text entry mode, there are several handy shortcuts. With frequency values, you can type e.g. '1k' to set the value to 1000
Hz. With dB values, you can type e.g. '2x' to get +6 dB (the value that corresponds to two times louder). With all values, you
can also type a percentage (e.g. '50%' will put a knob exactly in the middle position).

Pro Tools note: the RTAS/AS and AAX versions of our plug-ins implement the default Pro Tools keyboard shortcuts for fine
tune (Ctrl+drag on Windows, Command+drag on Mac OS X) and reset to default (Alt+click).

Sometimes, knobs in our plug-in interfaces are linked: these be adjusted simultaneously by holding down the Alt key while
dragging on one of them. For example, an output level and input level setting of a plug-in could be adjusted simultaneously
(in the opposite direction) this way.

Next: Dynamic parameters

See Also
Overview

10



Dynamic parameters
The section in the top-left corner of the FabFilter Pro-C user interface is where the conventional compression settings can be found:
input gain and panning, threshold and ratio. These determine the dynamic behavior of Pro-C. For in-depth background information
on these settings, see Compressor basics.

Knee
The Knee switch chooses between a custom soft knee that is different for each compressor style, or a simple hard knee. You
can view the resulting transfer function in the transfer function display.

Style
FabFilter Pro-C comes with 3 different styles of compression: Clean, an allround, low distortion, feedforward, program
dependent, soft knee style; Classic: a vintage, feedback, very program dependent style; and Opto: a relatively slow, very
soft knee, more linear opto style.

Input
The Input knob controls the amount of input gain that is applied before the input signal enters the compressor. If Expert mode
is active, it is also possible to pan the input signal.

Threshold
The Threshold knob sets the threshold at which compression begins. Lower thresholds give heavier compression.

Ratio
The Ratio knob sets the amount of compression. At a ratio of 10:1, just one dB of output signal above the threshold remains
for every 10 dB of input signal above the threshold. You can click on the small dots around the Ratio knob to jump to certain
fixed ratio amounts. If you move the knob completely to the left (1:1), no compression will take place. If you move it
completely to the right (infinity), everything above the threshold will be completely compressed away, making Pro-C act as a
limiter. 

Next: Time parameters

See Also
Compressor basics
Overview
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Time parameters
The time parameters section at the top of the compressor contains the attack and release settings.

Attack
The Attack knob sets the time after which gain reduction sets in. For transient-rich program material like drums, fast attack
times are needed to minimize overshoot. For other program material, too short attack times may dull the sound a bit.
FabFilter Pro-C is capable of very fast attack times and they are program dependent.

Release
The Release knob sets the time that the compressor takes to recover from gain reduction. The various compression
characteristics of Pro-C use different release models, and in most cases, the release time is very program dependent.

Auto Release
The Auto Release button enables a smart auto release feature. When enabled, the compressor adjusts the release time
depending on the current amount of gain reduction, so this actually introduces an additional form of program dependency.
When Auto Release is used, the Release knob changes into the Auto Release Speed knob that adjusts the overall effect of the
auto release feature on the release time.

Program dependency

The different compressor styles in FabFilter Pro-C all have their own kind of program dependency. This means that the compressor
reacts differently to different kinds of input (program material). For example, Pro-C will recover very fast from transients (fast
changes/peaks), but will react quite a bit slower after longer periods of gain reduction. Both the attack and release times are
program dependent.

The Classic style is by far the most program dependent style. Even at the fastest release time setting, the actual release time can
increase up to a few seconds! Also the Clean style uses a form of program dependency to sound smooth on various types of
program material. The Opto style implements only little program dependency.

Next: Output section

See Also
Compressor basics
Overview

12



Output section
When all audio is processed the way you want, it is sent to the output. The output section of the interface contains controls for
adjusting main volume. The output of the compressor and the dry (unprocessed) signal have their own output knob (and panning
rings when Expert mode is activated).

This allows for parallel compression. Parallel compression refers to mixing the dry signal with a compressed copy of itself. The
dynamics in the dry signal are preserved while the compressed signal adds body and character to the overall sound. The advantage
of this is that the sound is reinforced where it needs it, but without the risk of crushing any peak transients.

For example, you can smash the living crap out of the snare drum to get whatever effect you are looking for while at the same time
just lightly blending that snare into the mix. A very powerful function so we suggest you experiment with this.

The Auto Gain knob will help you to restore volume after compression. This is also known as "make-up gain" because it
compensates for the gain reduction introduced by the compressor.

Warning: Auto Gain is not a guaranteed way of getting the "right" result. Rather, it can be a useful tool while you are tweaking the
threshold and ratio parameters. Especially when using Expert mode functions like filtering, panning and side chain levels, it is better
to switch Auto Gain off and adjust the Output level manually.

Next: Displays

See Also
Overview
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Displays
FabFilter Pro-C comes with some very cool ways of looking at all the dynamic information.

On the left, you'll find the basic transfer function display which shows the input/output relationship. The horizontal axis
corresponds to the input signal level, and the vertical axis is the output level (measured in decibels). The red area in the display
shows the current signal level. Furthermore the threshold, ratio and knee are visible so you have a clear view on those compressor
settings. See Compressor basics for more information.

In the center is a very useful other window: the animated level display showing the actual input, output and gain-reduction levels
in a 2D animated display. Very useful if you want to know exactly what's happening. The input level is shown in grey, the gain
reduction as a red line, and the output level is yellow. Use the three small colored knobs underneath the display to adjust the
opacity of each of the three curves to your liking.

To the right, there are three very accurate peak level meters, which are always displaying the current input level, gain reduction
level, and output level as well. In addition, the output meter will freeze the peak level if it has clipped (shown in red). Click on the
red clipping indication to reset it.

Notes

The animated level display will slide under the knee display when Expert mode is enabled.

You can change the scale of the level display and the peak level meters with the Meter Scale drop-down button, ranging from
48 dB (the default) to 8 dB for very precise mastering purposes. The transfer function display always keeps the 48 dB range.

With the small Display Enabled button, you can turn off all animated displays in case you find them distracting. The peak
level meters will always be visible, though.

To save all display settings so they will be re-used in future plug-in instances, choose Options > Save As Default from the
plug-in's preset menu. The display settings will also be saved in songs.

If the output meter indicates clipping, this does not imply distortion in Pro-C: it can handle levels above 0 dB easily. Rather,
this indicates that the output signal might clip in another part of the audio chain, for example your sound card or host
software.

Next: Expert mode

See Also
Compressor basics
Overview
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Expert Mode
If Expert mode is activated with the button under the peak level meters, the animated level display slides away to reveal controls
that makes FabFilter Pro-C shine. In Expert mode, input and output controls get panning options and Pro-C is now capable of side-
chain compression, both with filtered or external side-chain inputs, but also mid/side compression, mostly used in mastering
studios.

Before you read on we recommend you to read Advanced compressor techniques and Mid/Side introduction.

Internal/external input

Normally, the side chain receives input from the regular plug-in input signal. In this case side-chain should be set to In.
Alternatively, the side-chain can receive its signal from any other track from your DAW. In this case the side-chain should be set to
Ext. (In VST hosts, the Ext option can be disabled. See VST plug-in versions.) Use the Audition button to listen to the side chain
signal exclusively.

Filtering

To narrow the frequency range on which FabFilter Pro-C will trigger, you can filter the side chain signal with steep 48 dB/octave
low-pass and high-pass filters. To adjust the filters, drag the triangular buttons in the middle of the side chain section to the left or
right. Alternatively, double-click a button to type a value directly. The filters will be bypassed completely when they are at the far
left and right sides of the filter controller. To drag both filters at once, either hold down the Alt/Option key or drag the highlighted
area between the buttons. Again, use the Audition button to listen to the filtered side chain signal.

Side chain gain

The side chain can be used very precisely because of its unique gain structure. In Pro-C it is possible to use stereo compression
stereo-linked or unlinked and best of all, you can have anything in between. By using the gain and panning knobs it is very easy to
precisely determine the level and channel which will be sent to each level detector of each channel.

If you put both volume levels at zero dB and both panning knobs in center position, Pro-C will be stereo linked because both
channel level detectors get the same audio signal. This means that if the left channel's signal rises above the threshold, the right
channel's gain will react the same way and will be reduced by the same amount as the left channel, and vice versa. This keeps the
stereo image from wandering from left to right when compressing a stereo mix.

If you then only turn the panning ring for the left signal to the full left position and the right panning ring to the full right position
Pro-C is unlinked. Now compression on both channels will work independently. (You can hold down the Alt/Option key to link both
panning rings.)

It is important to understand that all other settings will result in anything between linked and unlinked (but maybe also cross-
channel-compression).

Mid/Side compression

Pro-C has a special feature that sets it apart from most other compressors: Mid/Side compression. To turn Mid/Side mode on, click
the M/S button. The red indicator tries to make it clear that we're now using the two compression channels for two totally different
signals.

Let's begin with a simple example: Compress the Side information and leave the Mid unprocessed. First enable Mid/Side
compression with the M/S button. Now for the Mid channel level detector turn the inner level knob to the full left position. Leave the
Side level knob in the center position, but turn the Side panning ring fully clockwise to the S indicator:

This means that the input for the Mid channel level detector is reduced by -36 dB, so the Mid channel will not be compressed. The
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Side channel will be compressed, but the Side channel level detector will only take information from the Side part of the side chain
input (this is determined by the panning ring).

The gain reduction meter shows that there is no compression applied to the Mid channel. If you vary the gain of the Side channel
you'll hear a change in stereo spread.

Suppose we want the opposite: compress the Mid information and leave the Side unprocessed:

To eventually hear the right mix of the Mid and Side channels you can adjust the output panning ring. Now this can act like a
stereo enhancer! Play with these settings and you'll feel inspired for some great sounds or you can surgically treat your audio any
way you want. There is a lot you can achieve with FabFilter Pro-C. This is not only interesting for compressing material with much
Mid/Side difference, but also great to "duck" the Mid or Side with another track as its side-chain.

Here is one last example that compresses only the Side input signal using the Mid side chain signal:

Panning

Sometimes you'll find that your input signal is not balanced evenly between the right and left channel. This can make your
compression work erroneously. The panning ring of the input knob makes it possible to make sure the compressor works on a
evenly balanced stereo source. In addition to this you can also balance the output of the compressor and the unprocessed signal
independently. When Mid/Side is used it controls the mix between Mid and Side signal.

Notes

The side chain level knob and panning ring at the left side of the side chain section control the compressor channel that works
on the Left or Mid channel. Likewise, the righthand knob and ring control the compressor channel that works on the Right or
Side channel.

The panning rings in the side chain section determine from which channel mix the L/M or R/S detector takes its input.

If the side chain level panning rings are in the center position, L/R and M/S processing give the same result, because the
channels are always fully linked. Note that you can use the Ctrl/Command key to reset a panning ring.

You could use Pro-C solely as a mid/side processor by enabling M/S mode, setting Output to zero, and using the input and dry
mix panning rings.

Next: MIDI learn

See Also
Compressor basics
Overview
Component routing
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MIDI Learn
Controlling FabFilter Pro-C's parameters directly with MIDI is very easy using the MIDI Learn feature. With MIDI Learn, you can
associate any MIDI controller with any parameter.

Click the MIDI Learn button in the bottom bar to enter MIDI Learn mode. The interface dims and the parameters that can be
controlled are highlighted. Each parameter has a small text balloon that displays the associated controller number. Now do the
following to associate a controller number with a parameter:

1. Touch the control of the desired parameter in the interface that you wish to control. A red square will mark the chosen
parameter.

2. Adjust the slider or knob on your MIDI keyboard or MIDI controller that you want to associate with that parameter.

That's it! The parameter will now be controlled with the MIDI controller. You can now go back to step 1 to associate a different
parameter. Note that there is no warning when you associate a different knob with a controller number that is already used. It will
just be replaced.

To exit MIDI Learn mode, click the MIDI Learn button again, or click Close at the top of the interface.

Click the small menu drop-down button next to the MIDI Learn button to access the MIDI Learn menu:

Enable MIDI
This globally turns MIDI control of parameters on or off: useful in hosts that automatically send all MIDI events on a track to
all effect plug-ins associated with that track as well.

Clear
This submenu shows all parameter associations and lets you delete individual associations or clear all associations in one step.

Revert
Reverts to the last saved MIDI mapping (or the state when the plug-in was started).

Save
Saves the current MIDI mapping so Revert will go back to this state. The current mapping is automatically saved when closing
the plug-in.

Routing MIDI to effect plug-ins
For MIDI Learn to work properly, the plug-in need to actually receive MIDI of course. Depending on your host, it can be quite
difficult to route MIDI data to effect plug-ins. Here's how to do it in the most important hosts:

Logic Pro
Instead of adding FabFilter Pro-C to one of the insert slots, create a new Instrument Track, and click on the Instrument
slot. Then choose AU MIDI-controlled Effects > FabFilter > FF Pro-C. Now, the plug-in receives MIDI. To get audio into the
plug-in, click the 'Side Chain' drop down menu in Logic's plug-in header and choose the actual input track. Next, you can
mute that original track, so you only hear the audio through the plug-in. The only downside is that plug-ins with an external
side-chain cannot use it anymore.

Cubase
Simply create a new MIDI track and set its output to the Pro-C instance you would like to control via MIDI.

Pro Tools
Create a new MIDI track. From the MIDI input drop down menu, choose your MIDI device (if not already selected) and from
the MIDI output drop down menu, choose FabFilter Pro-C -> channel 1 for the instance you would like to control.

Ableton Live
First of all, create a new MIDI track. From the 'MIDI from' drop down menu, choose your MIDI device (if not already
selected). Then, in the 'MIDI to' drop down menu, choose the Audio track that has FabFilter Pro-C on it. NOTE: only the first
plug-in on any track can receive MIDI!

Next: Undo and redo
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Undo and redo
The Undo and Redo buttons at the top of the plug-in interface enable you to easily undo changes you made to the plug-in.

The Undo button at the left undoes the last change. Every change to the plug-in, such as dragging a knob, or selecting a new
preset, creates a new state in the undo history. The Undo button steps back through the history to restore the previous states
of the plug-in.

The Redo button cancels the last Undo command. It steps forward through the history until you are back at the most recent
plug-in state.

If the plug-in parameters are changed without using the plug-in interface, for example with MIDI or automation, no new undo states
are recorded.

The Undo and Redo buttons will disable themselves if there is nothing to undo or redo.

Next: A/B switch

See Also
Loading presets
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A/B switch
With the A/B feature in FabFilter Pro-C, you can easily switch between two different states of the plug-in.

The A/B button switches from A to B and back. Before switching, the current state of the plug-in is saved, so if you click this
button twice, you are back at the first state. The button highlights the currently selected state (A or B). In the example above,
the A state is active.

The Copy button copies the active state to the inactive state. This marks the current state of the plug-in and allows you to go
back to it easily with the A/B button. After clicking Copy, the button disables itself to show that both states are equal, so
there is nothing to copy anymore.

Next: Loading presets

See Also
Undo and redo
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Loading presets
Plenty of presets are provided with FabFilter Pro-C, giving a good idea of what you can do. You can either use the presets as they
are, or tweak them further to create your own unique settings.

To load a preset, click the preset button. The presets menu will appear with all available presets. Click a menu item to load
that preset. The currently selected preset is highlighted with check marks.

To explore the presets one by one, click on the little arrow buttons to the left and right of the main preset button. This will
load the previous or next preset in the menu.

The preset button shows the name of the current preset. If you have changed the preset by adjusting one or more parameters, the
name is dimmed to indicate that this is not the original preset anymore.

Tips

The Default Setting preset is loaded automatically when FabFilter Pro-C is started. To change the default settings, simply
overwrite this preset by clicking Options > Save As Default in the presets menu.

To open a preset outside the presets folder, click Options > Open Other Preset. This might be useful if someone sends you
a preset by e-mail, for example.

If somehow the factory presets are lost or not installed properly, click Options > Restore Factory Presets in the preset
menu to restore them.

MIDI Program Change and Bank Select
Loading a presets can also be done via MIDI, using Bank Select and Program Change messages. Click Options > Enable MIDI
Program Changes in the preset menu to enable or disable this feature. When enabled, the corresponding bank/program numbers
are shown in front of the preset name (for example: (2/65) My Preset). This means that you can load that preset by first sending a
Bank Select message to select bank 2 and then sending a Program Change message to select program 65.

Important: All the presets in your preset folder are numbered automatically, starting with bank 0 and program 0. This way, you
are able to access any of the presets via MIDI. However, this also means that when you add new presets to the menu,
bank/program numbers of other presets might change. Be aware of this when recording program changes in a session!

Next: Saving presets

See Also
A/B switch 
Using FabFilter Pro-C
Acknowledgements
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Saving presets
You can easily extend the included presets with new settings to build your own library of presets for FabFilter Pro-C that you can
reuse in various projects. This is also a good way to copy settings across multiple instances of FabFilter Pro-C in a session.

To save the current setting as a preset, click the preset button, and then click Save As. A standard Save dialog will appear. Type a
name for the new preset and click Save to finish.

In the Save dialog, you can also rename and delete existing presets and create a new folder to store presets in. New folders will
show up as new categories in the preset menu. (On Mac OS X, this should be done with the Finder.)

See How presets are stored to determine the preset folder location and learn more about factory presets.

Next: How presets are stored

See Also
Loading presets
Using FabFilter Pro-C
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How presets are stored
Presets for FabFilter Pro-C are stored in separate files with the .ffp extension (for FabFilter Preset). All presets reside in subfolders in
the main preset folder. The subfolders will show up as separate categories in the preset menu. You can also further divide the
subfolders into categories.

You can manage the preset files just like other files on your computer. The easiest way to do this is in the Save dialog that appears
if you are saving a preset. The preset menu will automatically reload itself with the changes when the dialog is closed.

Furthermore it is very easy to share your newly created presets with other users since FabFilter presets use the same file format on
both Windows and Mac OS X.

The default location of the main preset folder is My Documents\FabFilter\Pro-C for Windows, and
~/Library/Audio/Presets/FabFilter/FabFilter Pro-C for Mac OS X. To change this location, first copy all presets to the desired new
location, and then click Options > Change Preset Folder in the preset menu and select the new folder.

Restoring factory presets
If you have accidentally lost the factory presets, you can easily restore them by clicking Options > Restore Factory Presets in
the preset menu. This will install all factory presets again.

Next: Purchasing FabFilter Pro C

See Also
Saving presets
Using FabFilter Pro C
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Purchasing FabFilter Pro-C
Once you have downloaded and installed the evaluation copy of the FabFilter Pro-C, you may evaluate it during 30 days. Every time
you start the plug-in, you will see the following dialog:

While there are still days left, you can click Evaluate to start working with the plugin. If you want to keep using FabFilter Pro-C
after the evaluation period, you must buy a copy in the online FabFilter Shop by clicking the Buy Now button in the evaluation
dialog.

Go to the FabFilter Shop and purchase FabFilter Pro-C now 

We accept credit cards from all major companies, check payments, wire payments, and PayPal. The FabFilter Shop uses secure
connections and encryption: therefore your personal information is completely safe.

Within a few minutes after you have purchased your copy, you will receive an e-mail containing your personal license key. You use
this license key to turn the evaluation copy into a fully registered version without the evaluation dialog and the 30-day trial
restriction.

Note: If the evaluation period has expired but you didn't have the chance to properly evaluate the plug-in, you can request a new
evaluation period by contacting us at info@fabfilter.com .

Next: Entering your license key

See Also
Support
License agreement
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Entering your license key
After you have purchased FabFilter Pro-C in the online FabFilter Shop , you will immediately receive an e-mail containing your
personal license key. This license key will turn the evaluation version into a fully registered plug-in.

Start FabFilter Pro-C and click Enter License in the evaluation dialog, or click Enter License on the Help menu if the plug-in is
already running.

Copy the license information from the e-mail you have received and paste it into the text field. Make sure that you are copying
the entire license key including the Product and Licensee lines! If you are not sure what text to copy, just copy and paste the
whole e-mail.

After you have entered your license information, you will need to restart the plug-in host, so make sure you save your settings if
needed. From now on, you will be able to use FabFilter Pro-C for an unlimited period of time with full support via e-mail.

Tips

After your purchase, you can always retrieve your license key again by logging into your personal FabFilter account . Here
you can also keep track of all your orders and take advantage of great discounts when buying other FabFilter plug-ins!

To deauthorize your license key and remove it from the computer, click Deauthorize on the Help menu. If you temporarily
needed to install your license on another computer, or if you have transferred your license to someone else, this is the way to
deinstall your personal license key safely.

Next: Support

See Also
Purchasing FabFilter Pro-C
Support
License agreement
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Support
If you need help with problems or questions, and the help file does not provide an answer, please visit the support pages on our
web site.

Go to FabFilter Support 

From here, you have direct access to the customer support forum, very useful tutorial videos for all FabFilter plug-ins, online and
PDF versions of all our help files, and a section with extra downloads (such as presets, controller templates, older plug-in versions).

For sales-related questions and technical support, you can also contact FabFilter directly at info@fabfilter.com.

Reporting a bug

If you have encountered a bug in FabFilter Pro-C, first of all make sure that you are using the latest version of the plug-in, which
you can find at www.fabfilter.com/download . You can easily check the version of FabFilter Pro-C that you are using by clicking
Help > About in the plug-in interface. If the bug is still present in the latest version, please send us an e-mail at info@fabfilter.com
and include as much technical information as possible: operation system and version, host software and version, steps to reproduce
the bug, etc. Thanks in advance!

Next: Manual installation

See Also
Using FabFilter Pro-C
Acknowledgements
About FabFilter
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Manual installation
When installing FabFilter Pro-C, the installation program will try to copy the plug-in into the appropriate plug-ins folders, and in
most cases your host will recognize FabFilter Pro-C automatically. Otherwise, please follow these instructions:

Windows

On Windows, most hosts have their own VST plug-ins folder. So if you are using Windows and your host does not recognize
FabFilter Pro-C, you need to locate the proper plug-ins folder for your host first (it is usually shown in the Preferences or similar
dialog). Then, copy the file FabFilter Pro-C.dll from C:\Program Files\FabFilter\Pro-C (or C:\Program Files (x86)\FabFilter\Pro-C if
you are using a 32-bit host on 64-bit Windows) to the plug-ins folder that you have found and restart the host so it can reload all
its plug-ins. For the AAX version of Pro-C, copy the FabFilter Pro-C.aaxplugin folder to the common Pro Tools AAX plug-in folder on
your computer; for the RTAS version of Pro-C, copy the FabFilter Pro-C.dpm and FabFilter Pro-C.dpm.rsr files to the Pro Tools RTAS
plug-in folder on your computer.

Mac OS X

On Mac OS X, plug-ins are installed in the standard plug-in folders in the system Library folder. These are the only possible correct
locations:

Audio Units: /Library/Audio/Plug-Ins/Components

VST/VST3: /Library/Audio/Plug-Ins/VST and /Library/Audio/Plug-Ins/VST3

RTAS: /Library/Application Support/Digidesign/Plug-Ins

AAX: /Library/Application Support/Avid/Audio/Plug-Ins

Note: AU and VST/VST3 plug-ins may be placed in the user's Library folders under ~/Library/Audio/Plug-Ins as well.

If you still have problems, contact FabFilter Support .

Next: Component routing

See Also
Quick start
Support
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Component routing
To make sure you understand how audio is flowing through FabFilter Pro-C, this routing overview will make things more clear.

Next: VST plug-in versions

See Also
Overview
Expert mode
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VST plug-in versions
FabFilter Pro-C is available in both VST 2 and the new VST 3 formats. They can be installed and used both at the same time. The
VST 3 format can only be used by hosts that support it, for example Steinberg's Cubase 5. It has the advantage of easy side-
chaining, while in VST 2 it can be quite a hassle to get this to work properly. On the other hand, the VST 2 format is compatible
with more different hosts and it has more thorough MIDI support (i.e. polyphonic aftertouch).

VST 2
For the VST 2 format, there are four versions of the FabFilter Pro-C plug-in that form all combinations of mono/stereo and with or
without external side chain input:

FabFilter Pro-C (stereo without side chain)

FabFilter Pro-C (SC) (stereo with side chain)

FabFilter Pro-C (Mono) (mono without side chain)

FabFilter Pro-C (Mono SC) (mono with side chain).

The default VST plug-in does not have external side chain support because some hosts (e.g. Steinberg WaveLab) will not work
correctly otherwise.

The external side chain feature in FabFilter Pro-C (SC) works well in Ableton Live 6 and in Tracktion 2 (use Tracktion's Rack
feature to be able to route the side chain input).

With Steinberg Cubase, do the following to use an external side chain input:

1. Create a Group Channel track with Quadro configuration (in the More... menu).

2. Open the VST Connections window. In the Group/FX tab, locate the group bus you just created and right-click it to create
child buses for the Stereo and Stereo (Ls Rs) parts.

3. In the Mixer, insert FabFilter Pro-C (SC) in the group channel track.

4. You can now route the input audio signal track to the Stereo child bus. The side chain track must be routed to the Stereo
(Ls Rs) child bus. (The routing settings are found at the top of each channel.)

5. Use Pro-C's Audition feature to confirm that everything is routed as you want it.

Note: In earlier versions of Cubase, the Group/FX tab is missing from the VST Connections window. In this case, you must pan the
input track to the front of the quadro bus, and the side chain track to the rear of the quadro bus. If you are using Cubase 4, make
sure you have upgraded to at least version 4.02 to get everything to work.

Next: External Side Chaining

See Also
Quick start
Manual installation 
Expert mode
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External side chaining
FabFilter Pro-C offers the possibility of feeding an external signal to its side chain, so that you can make it trigger on a different
signal than the audio it is actually processing. Feeding a signal to a plug-in's side-chain inputs works slightly different in various
hosts. This topic describes the procedure for some of the most popular hosts around: Cubase, Logic Pro, Ableton Live and Pro
Tools.

To explain how it works, we use a scenario with two tracks. The first one contains the audio that we want to process with Pro-C,
which we'll call the main track from now. The second track contains the audio that we want to route to Pro-C's external side-chain
input and use as trigger signal. We'll call this track the side chain track.

After setting up everything according to the instructions below for your host, you can check whether everything is routed correctly.
Play the audio and enable FabFilter Pro-C's Audition button to listen to the side-chain signal. While auditioning, the real-time display
and metering show the side-chain level, so you can easily set a correct trigger threshold. Afterwards, disable the Audition mode
again. Now, you'll hear that Pro-C on the main track will react to the sound of the side-chain track. Of course, you can fine-tune
the plug-ins settings to customize the effect.

Cubase

Open Cubase and create a new empty project.

Add two audio tracks that we'll use as main track and side chain track.

Add audio files on both the main track and the side chain track. You can simply drag audio files from a Finder/Explorer
window onto a track.

Open the Mixer. In the main track, click on an empty insert slot and select the VST 3 version of FabFilter Pro-C in the
Dynamics menu (note the VST 3 icon which looks like ///).

Open FabFilter Pro-C's interface, enable Expert mode and set Side Chain to Ext.

In the plug-in header, click on the Activate Side-Chain button (right of the R/W buttons) to enable the external side chain in
Cubase.

At the top of the Mixer, set the output for the side chain track to the side-chain input of FabFilter Pro-C.

Logic Pro

Open Logic Pro and create a new empty project via File > New...

Add two audio tracks (via Track > New...) that we'll use as main track and side chain track.

Add audio files on both the main track and the side chain track. You can simply drag audio files from a Finder/Explorer
window onto a track.

Select the main track and add Pro-C in the first Insert effect slot.

Open FabFilter Pro-C's interface, enable Expert mode and set Side Chain to Ext.

In the right top corner of the plug-in interface header, in the 'Side Chain' menu, choose the side chain track. Now, the signal
from the side chain track is sent to FabFilter Pro-C's external side-chain input.

Ableton Live

Open Ableton Live and start with an empty arrangement. We'll use Track 1 as the side chain track and Track 2 as the main
track.

From the folder menu's on at the left top of Ableton Live's interface, drag different audio clips to the first empty slots of Track
1 and Track 2.

From the VST (or Audio Units) plug-in menu, also at the left top of Ableton Live's interface, drag FabFilter Pro-C onto Track 2,
the main track.

Open FabFilter Pro-C's interface, enable Expert mode and set Side Chain to Ext.

In Track 1 (the side chain track) in the 'Audio To' menu select 'Track 2' instead of the default 'Master'. Now, an extra menu
appears right below: choose 'FF Pro-C 3/4' instead of the default 'Track In' to route the track's signal to FabFilter Pro-C's
external side chain inputs.
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Pro Tools

Open Pro Tools and start a new empty session.

Create two audio tracks that we'll use as main track and side chain track. Add audio files to both track.

Open the Mix window to display the tracks with their Insert slots and Sends slots.

In the first 'Sends' slot of the side chain track, choose 'Bus 1'. The track view for Bus 1 will open: set its level slider to 0.0 dB
so the bus actually produces audio!

In the first 'Inserts' slot of the main track, choose Dynamics > FabFilter Pro-C.

Open FabFilter Pro-C's interface, enable Expert mode and set Side Chain to Ext.

Now, in the 'Key Input' menu of the plug-in interface (just above the FabFilter logo), choose bus > Bus 1 instead of the
default 'no key input'. Now, the audio from the side chain track is routed to Pro-C's external side chain input via Bus 1.

Next: License agreement

See Also
Quick start
Manual installation
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FabFilter Software License Agreement
1. Disclaimer

FABFILTER, FREDERIK SLIJKERMAN AND FLORIS KLINKERT, AUTHORS OF THIS FABFILTER PRODUCT, SPECIFICALLY DISCLAIM ALL
WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL FABFILTER, FREDERIK SLIJKERMAN AND FLORIS KLINKERT, BE LIABLE
FOR ANY DAMAGE A FABFILTER PRODUCT MAY CAUSE, INCLUDING BUT NOT LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL
OR OTHER DAMAGES.

2. Terms of Use

You may use an evaluation copy of this FabFilter product for an period of up to 30 days. Once the evaluation period has ended, you
must either purchase your copy, or remove it from your computer. If you have purchased your copy of this FabFilter product, you
may continue to use your evaluation copy beyond the end of the 30-day evaluation period until your license key arrives.

We encourage you to distribute the evaluation copy and give copies to friends, as long as there is no payment involved.

You may not reverse engineer, reverse compile, or disassemble any of the files in the distribution.

You are not allowed to distribute or copy the full version of any FabFilter product. The license key that you receive when purchasing
it is personal and confidential and may not be disclosed. The full version is a commercial program. It is a violation of international
copyright laws to give copies to other people. You may give them the evaluation copy, so they can purchase the program on their
own.

3. VST plugin technology

VST is a trademark of Steinberg Soft- und Hardware GmbH.

Next: Acknowledgements
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About FabFilter
Beautiful sound. Fantastic workflow. These are the foundations of FabFilter. We create powerful audio plug-ins with superb sound
quality and innovative interfaces.

A unique perspective

At FabFilter, we make the best possible tools for music production and audio processing. To achieve this, we continually rethink and
challenge industry standards: we've never been afraid of reinventing the wheel. Considering every little detail, we tune our
algorithms and interfaces until they sound perfect, look amazing and feel great to work with.

It's the sound that counts

Above everything else, you need superb sound quality. That's why we put a lot of effort into developing unique audio processing
algorithms, ranging from our famous resonating filters to transparent high-end EQ and dynamics processing.

Innovative interfaces, great design

Every FabFilter plug-in has an easy-to-use, well-designed interface aimed at providing unsurpassed workflow. Our plug-ins focus on
the task you're performing at that specific moment: they expose the features you need, when you need them. And because of our
special attention to design, you'll be delighted every time you open a FabFilter plug-in.

Don't take our word for it

We always set the highest standard for sound quality, usability and design to make truly great products that raise the bar on what
audio software can do. That's why we're very happy with the praise we've received from users and press alike:

"In the decade since the release of its first plug-in, One, FabFilter has made an indelible mark on the music production
landscape." - Computer Music magazine

"While many other software developers are busy trying to model hardware, FabFilter is leaving them in the dust by being
visionaries and reaching into the future. FabFilter stuff is just on another level." - Jeff Sanders

"FabFilter has an enviable reputation for making easy-to-use, powerful tools." - Music Tech magazine

FabFilter was founded in 2002 by Frederik Slijkerman and Floris Klinkert, and is based in Amsterdam, The Netherlands.

See Also
Support
FabFilter web site 

33

http://www.fabfilter.com/
http://www.fabfilter.com/

	FabFilter Pro-C Manual
	FabFilter Pro-C Help
	Table of Contents
	About FabFilter Pro-C
	Starting the Pro-C plugin
	Compressor basics
	Advanced compressor techniques
	Mid/Side introduction
	Overview
	Knobs
	Dynamic parameters
	Time parameters
	Output section
	Displays
	Expert mode
	MIDI learn
	Undo and redo
	A/B switch
	Loading presets
	Saving presets
	How presets are stored
	Purchasing FabFilter Pro-C
	Entering your license key
	Support
	Manual installation
	Pro-C Signal routing
	VST plug-in versions
	External side chaining
	License agreement
	Acknowledgements
	About FabFilter




