# Table of Contents

## Introduction
- About FabFilter Pro-L 2 ........................................... 3
- Quick start ............................................................. 5

## Using FabFilter Pro-L 2
- Overview ............................................................... 6
- Knobs and gain slider ............................................... 8
- Recommended workflow ............................................. 10
- Advanced settings .................................................. 12
- True peak limiting .................................................. 14
- Metering ............................................................... 16
- Loudness metering ................................................... 19
- Oversampling .......................................................... 21
- Dithering and noise shaping ..................................... 22
- Output options ....................................................... 24
- Surround and Dolby Atmos ....................................... 26
- Full Screen mode and resizing .................................. 28
- MIDI learn ............................................................. 30
- Undo, redo, A/B switch ............................................ 32

## Presets
- Loading presets ....................................................... 33
- Saving presets ......................................................... 34
- How presets are stored .......................................... 35

## Purchasing FabFilter Pro-L 2
- PurchasingFabFilter Pro-L 2 ...................................... 36
- Entering your license key .......................................... 37

## Support
- Support ................................................................. 38
- Upgrading to Pro-L 2 ................................................ 39
- Manual installation .................................................. 40
- VST plug-in versions ................................................ 41
- External side chaining ............................................ 42
- License agreement ................................................... 45
- Acknowledgements .................................................. 47
- About FabFilter ........................................................ 48
About FabFilter Pro-L 2

The limiter is an indispensable tool in modern mastering and mixing, and there are a lot of different flavors available on the market today. Some limiters try to be as transparent and 'safe' as possible, while others are designed to just go loud. One limiter may work best on rock music, while another performs best on electronic dance music.

FabFilter Pro-L 2 is a professional true peak limiter, that combines all these flavors and qualities in one plug-in, making it suitable for any type of music/audio. It can be as transparent as needed, and can go as loud as you want it to go. Equipped with excellent (loudness) metering, true peak limiting, surround support, oversampling and dithering, Pro-L 2 is everything you need in a limiter.

New in version 2

At first glance, FabFilter Pro-L 2 looks quite similar to its predecessor, but you'll soon discover many exciting new features and improvements that have been added to enhance your sound and workflow. Pro-L 2 features four brand-new limiting algorithms, surround processing, true peak limiting, full-featured EBU R128 loudness metering, and much more. Here's a list of the most important new features and improvements:

- **Four brand-new limiting algorithms**: Modern (the new 'best for all' default algorithm), Aggressive (great for EDM/dance), Bus (nice for drums, individual tracks etc; it's not meant to be transparent, rather the opposite), and finally Safe (its goal is not loudness, but to be safe and distortion free at all times).
- **Immersive audio and surround** support (up to 9.1.6 Dolby Atmos), including smart surround channel linking.
- **True peak limiting**. When enabled, the final true peak level won't exceed the specified maximum true peak output level of the plug-in.
- **Extensive loudness metering** (Momentary, Short Term and Integrated), following the ITU-R BS.1770-4 and EBU R128 loudness metering standards (also supporting ATSC A/85 and TR-B32), including true peak metering, LRA measurement, and customizable loudness meter scale and target levels.
- **Up to 32x oversampling**.
- **New display modes** with peak labels to show moments of high gain reduction.
- Optional **DC Offset filtering**.
- Optional **external side chain triggering**, useful for stem mastering.
- **Unity Gain** option, to easily listen to the effect of the current limiting at unity gain level.
- **Audition Limiting** option, to listen to the applied gain change (i.e. 'delta' signal) only.
- AudioSuite 'Analyze' option in the Pro Tools AAX plug-in to analyze audio at current...
limiter/metering settings without rendering.

- Lots of new factory presets.

**Other key features**

And of course, all the goodness of the original Pro-L is still there: highest possible sound quality and transparency, adjustable look-ahead, attack and release settings, separate channel link settings for transients and release, dithering with three different noise shape settings, accurate and insightful metering with various meter scales, GPU-powered graphics acceleration, double-click text entry of parameter values, Pro Tools hardware control surfaces support, MIDI Learn, undo/redo and A/B comparison, extensive help file with interactive help hints.

**Upgrading to Pro-L 2**

Upgrading from Pro-L version 1 to the new Pro-L 2 is safe and easy: installing Pro-L 2 will not replace or delete the previous Pro-L 1 plug-in. Both versions will co-exist and can both be used at the same time. This ensures that you can open old songs that use Pro-L 1 without problems! Of course, FabFilter Pro-L 2 opens all presets from Pro-L 1 without problems. See [Upgrading to Pro-L 2](#) for more information.

FabFilter Pro-L 2 is available in VST, VST3, AU (Audio Units), AAX Native and AudioSuite formats.

<table>
<thead>
<tr>
<th>Windows requirements</th>
<th>macOS requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 10, 8, 7 or Vista</td>
<td>macOS 10.12 or higher (64-bit only)</td>
</tr>
<tr>
<td>64-bit or 32-bit</td>
<td>AU or VST 2/3 host or Pro Tools</td>
</tr>
<tr>
<td>VST 2/3 host or Pro Tools</td>
<td>Intel or Apple Silicon processor</td>
</tr>
</tbody>
</table>

[Next: Quick start](#)

**See Also**

[Using FabFilter Pro-L 2](#)
[Acknowledgements](#)
Quick start

The installer will copy the FabFilter Pro-L 2 plug-in into the common VST, VST 3, AU (macOS only) and Pro Tools plug-in folders on your computer. On macOS, the global plug-in folders in /Library/Audio/Plug-Ins are used.

In most cases, your host will then recognize the plugin automatically. However, if the instructions below do not work, see Manual installation instead.

- **Pro Tools**
  Choose an empty insert slot on one of your audio tracks, instrument tracks or buses and select FabFilter Pro-L 2 from the pop-up menu in the Dynamics section.

- **Studio One**
  Click the '+' button next to the Inserts tab of an audio track, instrument track or bus and select 'FabFilter Pro-L 2' from the drop-down menu.

- **Logic Pro**
  Choose an empty insert slot on one of your audio tracks, instrument tracks or buses and select FabFilter Pro-L 2 from the pop-up menu. You will find FabFilter Pro-L 2 in the Audio Units > FabFilter section (named Pro-L 2).

- **Ableton Live**
  In Session view, select the track you would like to place FabFilter Pro-L 2 on, for example by clicking the track name. At the left top of Ableton Live's interface, click on the Plug-in Device Browser icon (third icon from the top). From the plug-ins list, double-click FabFilter/FabFilter Pro-L 2, or drag it onto the track.

- **Cubase**
  Choose an empty insert slot, for example in the Mixer, and select FabFilter Pro-L 2 from the menu that appears. To use the MIDI features in Pro-L 2, create a new MIDI track and set its output to the Pro-L 2 instance you have just created. (The VST 3 version of Pro-L 2 can be found in the Dynamics section.)

To begin, just open the plug-in and move the Gain slider. Enjoy!

Next: FabFilter Pro-L 2 overview

See Also
About FabFilter Pro-L 2
Overview

The interface of FabFilter Pro-L 2 is designed to eliminate clutter while providing as much information as possible. It consists of the following elements:

- **Real-time level display**
  The real-time moving level display shows you at a glance what's happening to your audio. It shows input (gray / light blue), output (dark blue) and gain reduction (red) levels, together with the loudness level (thin line). In addition, peak labels are shown for the most significant gain reduction peaks. See Metering and Loudness metering.

- **Gain slider**
  The Gain slider is the most important control: it adds gain to the incoming signal to make it louder, while limiting to the maximum output level specified in the bottom bar. See Knobs and gain slider and Recommended workflow.

- **Level/loudness metering**
  The output level meter, gain reduction meter and large loudness metering on the right provide an immediate overview of the current levels, together with accumulating level readings above the meters. The metering options at the left bottom of the output level meter offer various metering scales (including Loudness, K-12, K-14 and K-20 scales) and an option to enable/disable true peak metering. See Metering and Loudness Metering.

- **Advanced settings**
  The advanced settings panel lets you customize FabFilter Pro-L 2’s behavior by selecting different limiting styles and tweaking their settings. See Advanced settings.

- **True Peak Limiting**
  With True Peak Limiting enabled, the true peak output is ensured not to exceed the currently set Output Level in dBTP. See True peak limiting.

- **Oversampling**
  The Oversampling setting sets the amount of internal oversampling, which reduces aliasing and generation of intersample peaks at the cost of additional CPU usage. See Oversampling.

- **Dithering and noise shaping**
  The Dither and Noise Shaping settings specify whether and how the output signal is dithered. Dithering helps to preserve (perceived) detail and resolution by reducing quantize distortion. See Dithering and noise shaping.

- **Input and output options**
  On the far right of the bottom bar, you can bypass the entire plug-in, adjust the final output level or enable Unity Gain, Filter DC Offset, Side Chain Triggering or Audition Limiting. See Input and output options.

- **Resize**
  The resize button in the lower-right corner lets you choose an interface size and switch to Compact mode. See Full Screen mode and resizing.

- **MIDI learn**
  MIDI Learn lets you easily associate any MIDI controller with any plug-in parameter. See MIDI Learn.

- **Presets, undo, A/B, help**
  With the preset buttons, you can easily browse through the factory presets or save your own settings so you can re-use them in other songs. The Undo, Redo, A/B and Copy buttons at the top of the plug-in interface enable you to undo your changes and switch between different states of the plug-in. Finally, the Help menu provides access to help and version information. See Loading presets and Undo, redo, A/B switch.
Knobs and gain slider

It is easy to control FabFilter Pro-L 2's parameters with the large round knobs. They will light up when you move the mouse cursor around to indicate that you can adjust them. The moment you move the mouse cursor over a knob, a parameter value display will pop up, which shows the name and the current value of the parameter.

All knobs support four ways of control:

1. **Vertical mode**
   Click on the center area of a knob and drag up or down to rotate it. The knob reacts to the speed with which you are dragging, so if you move the mouse slowly, you make precise adjustments.

2. **Rotate mode**
   Grab the arrow of the knob and drag it around. By moving the mouse cursor further away from the knob while dragging it, you can make precise adjustments.

3. **Mouse wheel mode**
   Perhaps the easiest way to make adjustments is by using the mouse wheel when you hover over a knob. This mode works for all the knobs and possible panning rings. (On Windows, you might need to click in the plug-in interface first to make sure it is the active window.)

4. **Text entry mode**
   Double-click a knob to enter an exact value using the keyboard.

**Tips**

- To **reset** a knob to its default position, hold down the Ctrl key (Windows) or Command key (macOS) and click the knob once. Note: In Pro Tools, Pro-L 2 uses the default Pro Tools keyboard shortcut for reset: Alt+click.

- To **fine-tune** a value when using vertical drag mode or the mouse wheel, hold down the Shift key while dragging or moving the mouse wheel. Note: In Pro Tools, Pro-L 2 uses the default Pro Tools keyboard shortcut for fine tune: Ctrl+drag on Windows or Command+drag on macOS.

- There are several **handy shortcuts in text entry mode**. With frequency values, you can type e.g. '1k' to set the value to 1000 Hz, and also 'A4' for 440 Hz, or even strings like 'C#3+13'. With dB values, you can type e.g. '2x' to get +6 dB (the value that corresponds to two times louder). With all values, you can also type a percentage (e.g. '50%' will put a knob exactly in the middle position).

- Sometimes, knobs in our plug-in interfaces are **linked**: these be adjusted simultaneously by holding down the Alt key (Shift key in Pro Tools) while dragging on one of them. For example, an output level and input level setting of a plug-in could be adjusted simultaneously (in the opposite direction) this way.

Gain slider

The gain slider adjusts the threshold of limiting and the increase in output gain at the same time. Simply put, it makes your audio louder, while respecting the current maximum output level. You can control the gain slider in the following ways:

- **Mouse**: simply click anywhere on the slider and drag the mouse up and down, or use the mouse wheel while hovering above the slider. If you click on the slider background and move the mouse slowly, you make more precise adjustments.

  The Gain slider is reverse-linked to the Output Level parameter, so holding down the Alt key (Shift key in Pro Tools) while increasing the gain, will decrease the output level with the same amount. This way, you can easily test how the limiting affects the audio without changing the apparent volume.

- **Text entry**: Double-click on the slider to enter the value exactly using the keyboard.
**Recommended workflow**

To get the best results with FabFilter Pro-L 2, we recommend the following steps:

**Step 1: Choose a good starting point preset**

Of course, the simplest way to start working with Pro-L 2, is to just open it with its Default Setting preset and move the Gain slider up until you reach the desired level. We have chosen the default preset carefully, to work well on almost any audio.

Instead of just using the default settings however, you can also try one of the excellent factory presets that come with FabFilter Pro-L 2. They are divided per musical genre and have descriptive names, so you can easily choose the preset that works best for your purpose and audio material.

To make it easy to try and compare different presets on your audio, while leaving the current amount of limiting, the specified output level and other output settings unaffected, make sure the **Lock Output** button is enabled. It's placed directly right to the preset controls, at the top of the interface. When enabled, the current values of the Gain, Output Level, DC Offset Filtering, Unity Gain, True Peak Limiting, Oversampling, Dithering and Noise Shaping parameters will be preserved while loading presets.

After a while, you'll probably have a favorite preset and favorite settings that you use most of the time. In that case, it's a good idea to override the Default Preset so that the next time you open FabFilter Pro-L 2, you're ready to go right away. To save all current settings as default, simply choose **Options > Save As Default** from the preset menu.

**Step 2: Refine settings if needed**

If you like to, you can of course adjust or refine the settings that influence the sound and flavour of limiting. Just open up the Advanced panel to get access to settings like Style, Lookahead, Attack, Release and Channel Link. To learn how to interpret these settings and adjust them with sense, see **Advanced settings**.

**Step 3: Set up True Peak Limiting, Oversampling, Dithering and Output level with care**

The final step in setting up the limiter is choosing the correct output settings. Whether you use dithering and noise shaping depends on your preferences and requirements. See **Dithering and noise shaping** for more information.

"So what's an appropriate Output Level setting? Should I choose -0.1 dB, -0.3 dB or -1.0 dB?"

Actually, there is not a single correct value for the **Output Level** parameter. It mainly depends on the presence and strength of **true peaks** (or **inter-sample peaks**) in the outgoing audio signal. Different metering and loudness standards allow for different maximum peak (i.e. true peak) levels.

In short, our advice is simple. Turn on **True Peak Limiting** and **True Peak Metering** (also known as **inter-sample peak** metering), which exposes true peaks in the processed signal. Then set the Output Level to the maximum allowed value (e.g. -1.0 dBTP for EBU R128).

In any case, make sure that the true peak output level never exceeds 0.0 dBTP. This makes it very likely that a subsequent D/A conversion (or any other conversion, like to MP3 etc.) will handle your audio without introducing distortion.
Notes

- Not everyone cares about true peaks or inter-sample clipping: see Output options for the full discussion.

- Inter-sample peaks are introduced when the limiter needs to react very quickly to the incoming signal. By increasing the Lookahead setting, you allow the limiter more time to respond, and therefore reduce distortion and inter-sample peaks.

- Another way to reduce inter-sample peaks and true peak overshoot is by using oversampling. In most cases, choosing 4x oversampling in combination with a minimum lookahead time of 0.1 ms, keeps inter-sample peaks within the range of 0.1 dB.

- The best way to ensure a maximum true peak level, is by enabling True Peak Limiting. This will smooth out the true peak overshoot after processing, ensuring the output never exceeds the current Output Level.

- Of course, Pro-L 2’s True Peak metering fully complies to the EBU R128 / ITU-R 1770 metering standards.

Next: Advanced settings

See Also
Overview
Knobs and gain slider
Advanced settings

Most of the time, choosing the right preset from FabFilter Pro-L 2’s preset menu works very well. But in some cases, you might want to adjust and fine-tune the limiting behavior. To access Pro-L 2’s advanced settings, click the Advanced button right under the Gain slider at the left of the interface, which makes the advanced panel slide out. Clicking the button again will hide the panel.

Style

FabFilter Pro-L 2 comes with eight advanced and highly program-dependent limiting algorithms, which all have their own distinct character. One is not better than the other; they are all great, and they all go very loud if you want them to. It is best to select the appropriate algorithm depending on what kind of effect you want to achieve: some are designed to be as transparent as possible, while others may add a nice punch or flavor.

The default Lookahead, Attack and Release values are good starting points but feel free to tweak these to get the best possible results. Here's a short description of all algorithms:

- **Transparent**: As the name says, this algorithm is designed to stay true to the original sound and feel as much as possible, avoiding pumping effects and coloring. It works great on most program material, but especially on rock and pop music.

- **Punchy**: Of all algorithms, this one is the most apparent. When pushed, it becomes quite punchy and will introduce a bit of pumping, which can add some nice flavor. Since it’s fairly ‘safe’, minimizing distortion most of the time, it works miracles on single tracks, like vocals, bass or guitar and can give a nice edge to beat-oriented music.

- **Dynamic**: By enhancing transients before actually applying limiting, this algorithm excels in preserving the original punch and clarity of your audio. It’s great on rock music, but it can work surprisingly well on other types of audio as well.

- **Allround**: This algorithm is designed to work well on almost any program material, striking a good balance between loudness and transparency.

- **Aggressive**: As the name implies, this algorithm uses an aggressive yet smart, near-clipping style of limiting. This works wonders on EDM/trance music but also shines on rock, metal or pop.

- **Modern**: As the new default style in Pro-L version 2, the Modern algorithm sets the new standard for all-purpose, transparent limiting. It can achieve very high loudness and allows for very near-zero lookahead settings, while still sounding extremely clean and natural.

- **Bus**: Especially nice for (drum) bus processing and individual tracks, this algorithm is not meant to be transparent, rather the opposite. Think glue, pump or squash!

- **Safe**: No distortion ever, that’s what this algorithm is designed to achieve. It’s perfect for delicate acoustic and/or classical music, or individual instrument tracks.

Note that some algorithms (especially the last four new algorithms introduced in Pro-L version 2) need more latency than others. Do you need to minimize processing latency? Then choose one of the first four algorithms (e.g. Transparent) and disable True Peak Limiting and oversampling.

Lookahead

The Lookahead knob sets the look-ahead time for the initial ‘transient’ stage. This allows the limiter to examine the incoming audio in advance and predict the amount of gain reduction needed to meet the requested output level. If the look-ahead time is very short, the limiter doesn’t have much time to move to the desired level: this will generally have the effect of preserving transients better and increasing the apparent loudness, but at the expense of possible distortion. Longer look-ahead times are safer, but less loud, and transients might appear to get lost in the mix a little more.

Very short look-ahead times (less than 0.1 ms) will approximate ‘hard clipping’, introducing distortion and aliasing. This causes more inter-sample peaks which can cause further distortion later on. To reduce aliasing and inter-sample peaks, we advise to use oversampling. Also, turn on True Peak Metering to visualize the inter-sample peaks generated, and enable True Peak Limiting to attenuate the remaining true peak overshoot.
Attack and Release

Apart from the fast ‘transient’ stage, the limiter has a slower ‘release’ envelope stage that responds to the average dynamics of the incoming audio. The Attack and Release knobs control how quickly and heavily the release stage sets in. Shorter attack times will allow the release stage to set in sooner; longer release times will cause it to have more effect.

In general, short attack times and long release times are safer and cleaner, but they can also cause pumping and reduce clarity. On the other hand, long attack times and short release times can increase apparent loudness and presence, but at the expense of possible distortion.

Channel linking

When limiting a stereo signal, it is generally desirable to process both channels in the same way to avoid changing the stereo image inadvertently. However, when a short peak occurs in one channel, removing it is often almost inaudible. In this case, it is better to remove it only in the channel where it occurs.

You can control this behavior completely with the two channel linking knobs. The Transient knob controls the amount of channel linking for the ‘transient’ stage that mainly operates on short peaks. It often works well to choose less than 100% here. The Release knob controls the channel linking for the ‘release’ stage, where it is best to start with 100% which will completely link the channels. However, you can of course experiment with different settings depending on the level of limiting and the character of the incoming audio signal.

When using Pro-L 2 for surround/immersive audio processing, the Channel Linking section will offer more controls, tailored especially to deal with surround channels. See Surround and Dolby Atmos. Of course, in the mono version of the plug-in, the Channel Linking controls are simply disabled.

Tips:

- When you first start to work with FabFilter Pro-L 2, try to use the factory presets. These are great starting points, smartly divided in music categories, and with descriptive names. These might just do the trick already, without even needing to open the Advanced Panel.

- If you have found a preset that you really like, which works well on most music you usually process, you can easily save it as the default preset! Just choose Options > Save As Default from the plug-ins preset menu, and the next time, Pro-L 2 will start up with your favorite settings.

- Using Pro-L 2 for surround/immersive audio processing? See Surround and Dolby Atmos.

Next: True peak limiting

See Also
Overview
Recommended workflow
True peak limiting

Digital audio processing, and especially ultra-fast limiting or hard clipping in the digital domain, can introduce inter-sample peaks. In this case, the analog signal that a D/A converter would generate from the sample values becomes higher than the individual sample values. Depending on how good the D/A converter is, this can cause audible clipping. The same happens during operations like MP3 conversion.

![Diagram showing True Peak Limiting](image)

As illustrated by this image, the analog signal (blue) has a peak (green) that is higher than the sample peaks in the digital signal. Peaks like these are called inter-sample peaks or **true peaks**. Today, many commonly used metering/loudness standards, like EBU R128 or ATSC A/85 impose a maximum allowed true peak level.

To guarantee that FabFilter Pro-L 2's output doesn't exceed a certain maximum true peak level, enable the **True Peak Limiting** option in the bottom bar.

[Image of FabFilter Pro-L 2 interface]

True Peak Limiting works at two different stages:

- The limiting process will detect true peaks that already exist in the input signal, and reduce them appropriately.
- Any true peak overshoot introduced by the ultra-fast limiting process itself, will be smoothly attenuated afterwards, ensuring the final true peak output doesn't exceed the current maximum true peak Output Level.

When using True Peak Limiting, it's best to keep True Peak Metering enabled as well, using the **TP** button next to the display and meter scale settings. The output level meter will then show the actual true peak levels (with level reading in green to reflect this). See **Metering**.

Of course, FabFilter Pro-L 2's true peak metering system fully complies with the ITU-R BS.1770 and EBU R128 standards, and is suitable for MFIT (Mastered for iTunes).

**Preventing true peak overshoot**

Instead of letting the true peak limiting process deal with remaining true peaks in the output, it's even better to prevent high true peak overshoot in the first place. The best way to minimize inter-sample peaks and distortion, is to use **oversampling**. In addition, increasing the **lookahead** can also help quite a lot, but may affect loudness and transparency.

In most cases, choosing 4x oversampling in combination with a minimum lookahead time of 0.1 ms, keeps inter-sample peaks within a range of 0.1 dB.

**Tips**

- When True Peak Limiting is enabled, the Output Level read-out and parameter value display will show its value as "dBTP" (dB True Peak) instead of "dB" (dBFS or dB Full Scale).
- The additional processing needed for true peak limiting will introduce a bit of extra latency (about 5 ms). If you need to minimize latency, you can disable true peak limiting and **oversampling** and
choose one of the limiting styles from Pro-L version 1 (e.g. Transparent).

Next: Metering

See Also
Overview
Recommended workflow
Metering

Accurate metering is extremely important in a limiter plug-in. To give you a perfect view of what's happening to your audio, FabFilter Pro-L 2 offers very accurate output and gain change meters, including a textual representation of maximum peak levels, as well as a large real-time level display, showing levels and limiting over time.

Using the **Meter Scale** button, you can choose between three normal scales and three K-Metering scales, as well as a dedicated Loudness scale for loudness metering.

**Normal metering scales**

FabFilter Pro-L 2 has three normal metering scales. All three general scales have linear precision in the upper part of the metering, offering the best precision where limiting mostly happens:

- **16 dB**: Showing the top 5 dB of input, output and gain reduction meters in the linear upper part of the metering, this scale offers a precise view of limiting in the top ranges.

- **32 dB**: With a bit less, but still enough detail, combined with a fairly large overall range, this scale offers the best of both worlds: good insight in the applied limiting and a proper impression of overall levels.

- **48 dB**: Covering a wide range of 48 dB, this scale gives you a general overview of input and output levels.

Like the K-System meters described below, the normal output meter shows the RMS level and the peak level at the same time. The RMS level follows the Momentary specification of the EBU R128 standard, and is shown per-channel and also as a combined level for all channels.

Above the meters, the maximum peak output level and gain reduction is displayed. The peak level is shown in green if **True Peak Metering** is enabled (see below). Click on the level text to reset the reading.

**K-System metering scales**

The K-System, introduced by mastering engineer Bob Katz in 1999, is a protocol for setting mix and monitor calibrations in a studio environment. Although loudness standards like EBU R128 are more widely used nowadays, the K-System is still a useful way to regulate audio levels. It uses three separate standards known as K-20, K-14, and K-12. With each step (from K-20 to K-12), the available dynamic range decreases as the average level increases. The top label of the meter scale indicates the maximum head-room (either 20dB, 14dB or 12dB), and just as with normal metering this matches the full-scale digital signal. Your monitor gain should be calibrated carefully, so that the level at the 0 dB label of the meter matches 85 dBC SPL.

The K-System meters show both peak and RMS level at the same time. The top red zone of the meters is the *loud or fortissimo* zone. In music recording, the RMS level should only reach the red zone in the loudest passages, climaxes or occasional peak moments. If you find yourself using the red zone all the time, you might want to check whether your monitor gain is properly calibrated.

- **K-12**: This scale is intended to be used exclusively for broadcast material, be it radio or television. With this system, -12 dBFS = 0 VU = 85 dB SPL. The limited headroom of 12 dB explains its exclusiveness to heavily compressed broadcast material.

- **K-14**: This should be the standard for the majority of commercial recordings created for home listening. Pop music and home theatre mixes are examples of material that would fall under K-14, where -14 dBFS = 0 VU = 85 dB SPL. The available headroom is 14 dB. The K-14 scale is probably the most widely used of the three standards.
K-20: Offering the widest available dynamic range of the three systems, this scale should be used primarily for large theatrical mixes, dynamic music mixes, and classical style mixes. Any material with a wide dynamic range should be reserved for the K-20 standard. In this system, -20 dBFS = 0 VU = 85 dB SPL and the headroom is 20 dB.

To read more about the K-System and how to use it properly (including monitor gain calibration), read Bob Katz' article: An Integrated Approach to Metering, Monitoring, and Levelling Practices.

The real-time level display
The large real-time level display shows input level (gray / light blue), output level (dark blue), gain reduction (red) and loudness level (thin line) at the same time. Gain reduction peaks are highlighted with yellow peak level readings. The display gives you a very good insight in the amount of limiting going on, and the overall peak and average levels.

The Display Mode button selects the behavior of the real-time level display:
- **Slow Down** lets the display move slowly so you can easily follow the levels and the peak gain reduction labels. Once the incoming audio reaches the rightmost display edge, the display quickly scrolls back to make room for new audio.
- **Fast** is the behavior from Pro-L 1 where the display moves fairly quickly at a steady pace.
- **Slow** is the same, but with a slower pace so you can see more audio history at a time. This mode works well in combination with **Short Term loudness metering**.
- **Infinite** shows all incoming audio since the interface was opened or this mode was selected, increasing the density each time the display fills up. This mode works well in combination with **Integrated loudness metering**.
- **Off** turns the display off altogether which is useful if you find it distracting while listening.

True Peak Metering
Digital audio processing, and especially ultra-fast limiting or hard clipping in the digital domain, can introduce inter-sample peaks. In this case, when converting the digital signal back to analog, a D/A converter will generate an analog signal that is actually higher than the individual digital sample values. Peaks like these are called **inter-sample peaks** or **true peaks**. Depending on the quality of the D/A converter, these peaks can cause audible clipping and distortion.

Of course, it's always best to minimize inter-sample peaks, and at the same time make sure that any peaks in your audio, both normal or inter-sample, stay within the ceiling set by the **Output knob**. Then you can be sure that D/A conversion (and also other operations like MP3 conversions) do not introduce unwanted distortion.

FabFilter Pro-L 2 offers two tools to ensure this:
- **True Peak Limiting** guarantees that inter-sample peaks in the output signal stay under the chosen ceiling level. See True peak limiting.
- **True Peak Metering** lets you view inter-sample peaks in the output meter so you can verify that this works correctly.

The TP button next to the meter scale button turns true peak metering on and off.

If true peak metering is enabled, the TP button displays a green light. In addition, the maximum peak level reading above the output meter is shown in green to reflect that it is a true peak level reading. It will turn orange when true peak levels exceed the current Output Level and red when exceeding 0 dBTP. We recommend to always turn on true peak metering unless you are interested in the difference between the sample peaks and the inter-sample "true" peaks.

Of course, FabFilter Pro-L 2's true peak metering system fully complies with the EBU R128 and ITU-R BS.1770 standards.

Tips:
- When skipping through presets, the current metering settings are not changed, but they are saved in sessions. In addition, any change you make is automatically saved as the default setting, used when opening a new instance of Pro-L 2.
When using Pro-L 2 for surround/immersive audio processing, the meter section will show all channels in logical order and appropriately grouped. See Surround and Dolby Atmos.

You can also switch to the Compact interface layout to hide the real-time display and see larger output meters. See Full Screen mode and resizing.

Note that true peak metering isn’t exact science: there are many different ways to implement ITU-R BS.1770 compliant metering, which might result in slightly different readings. Differences of 0.1 or 0.2 dBTP between different true peak meters are not unusual. Our true peak meters use high internal oversampling and have been verified with all test audio as provided by ITU itself to ensure compliance. Also, it’s suitable for MFIT (Mastered for iTunes).

Next: Loudness metering

See Also
Overview
Recommended workflow
Loudness metering

In the early 90s the introduction of digital signal processors and better limiters allowed engineers to increase perceived audio levels in a recording (i.e. loudness) significantly. And because “louder” is generally perceived as better, naturally many engineers tried to push loudness to the limit, which led to the loudness war. Many engineers in the music and broadcast industry believe that this race for audio level led to a point where the quality of the audio was jeopardized, sacrificing quality for level.

One of the problems is that peak measurements are not a good way to describe the loudness of a piece of audio, so normalizing audio to a maximum peak level doesn’t work well. What’s needed is a way to measure loudness as the human ear perceives it, and use this for loudness normalization. An early attempt is the K-system (see Metering) developed by Bob Katz, but the most commonly used standards today like EBU R128 and ATSC A/85 are based on the ITU-R BS.1770-4 standard.

The ITU-R BS.1770-4 standard describes a way of pre-filtering the audio signal to mimic the way the human ear perceives different frequencies, together with a way to calculate the average (RMS) signal level and use it to calculate a loudness level for an audio fragment of any length. This loudness level is expressed in LUFs (Loudness Units Full Scale) and is typically combined with true peak level metering.

FabFilter Pro-L 2 implements this standard and offers elaborate loudness metering. Simply set the Meter Scale button to Loudness to enable it. This opens the loudness panel at the righthand side of the interface:

- The **Loudness Meter Target** button sets the desired target level in LUFS. The following common target levels are available as preset options: -9 LUFS (commonly used for audio CDs), -14 LUFS (roughly the target level used by streaming services like Spotify, iTunes or YouTube), -23 LUFS (the EBU R128 standard), or -24 LUFS (ATSC A/85 and TR-B32 standards). Click Custom in the menu that appears to enter a custom target level. Roughly speaking, the loudness target is the desired value for the Integrated loudness measurement (see below).

- The **Loudness Time Scale** button at the bottom chooses which loudness time scale is displayed prominently in the loudness meter: Momentary for a continuously changing reading that reflects the current loudness level, Short Term for a more slowly changing level that represents the overall loudness of the current audio, and Integrated for a long-term measurement that combines all audio analyzed by the meter since the last reset. The Integrated measurement gives the overall loudness of an entire song, album or movie and this is the value that is should end up at the chosen loudness target when performing loudness normalization.

- The **Loudness Meter Scale** button selects the desired meter scale: either +9 or +18 LU above the chosen loudness target level. These scales comply with the EBU mode from the EBU R128 standard and if you have chosen the -23 LUFS target, the meter scale button shows the required “EBU +9” or “EBU +18” labels. In addition, the menu that pops up also lets you change the meter scale between absolute and relative readings (in this case, the target level is shown as zero).
The **loudness meter** displays the chosen loudness measurement prominently, next to the other two time scales that are shown as small bars. Below the loudness meter, the **loudness reading** displays the loudness as a text readout.

The **loudness curve** displays the overall loudness over time in the real-time level display. Because the loudness meter doesn't use the same scale as the output meter and the level display, curved lines indicate how the scales are related to each other.

Just like in the regular metering modes, the **maximum true peak level** is displayed above the output meter if you have **True Peak Metering** enabled with the **TP** button next to the meter scale button. See **Metering**.

Above the loudness meter, the **maximum momentary** or **maximum short term** level is displayed. When the Integrated loudness time scale is used, you can select which one you want to see with the Max M / Max S button next to the peak reading.

If the time scale is set to Integrated, the **loudness range (LRA)** is also displayed to the left of the loudness meter. This is a measure for the variation of the loudness over time as defined by the EBU R128 standard.

You can **pause** or **reset** the loudness measurements with the small buttons at the sides of the time scale button. The reset button also resets the maximum peak and gain reduction readings on the regular meters.

How you should use this set of loudness measurements depends on the purpose of the audio you're working on. For example, you might need to comply with the EBU R128 standard for broadcasting. In this case, you would choose the -23 LUFS target level. By tweaking the **gain slider**, you can make sure the integrated loudness ends up at the target with a tolerance of +/- 1 LU. In addition, the maximum true peak level should not exceed -1 dBTP: you can simply enable **True Peak Limiting** and set the **Output Level** to -1 dBTP to achieve this.

When preparing music for a streaming service such as Spotify, you would choose the -14 LUFS target level and vary the gain to achieve an integrated loudness measurement that roughly matches this target level. Again, we recommend to enable True Peak Limiting and True Peak Metering and set the Output Level to -1 dBTP to make sure the maximum true peak level does not exceed -1 dBTP.

**Notes**

- There are four revisions of the ITU-R BS.1770 standard. In revision 2, the concept of gated loudness measurement was added, which reduces the influence of very soft passages on the overall integrated loudness level. FabFilter Pro-L 2 implements **ITU-R BS.1770-4** which also describes how to weigh surround channels properly. Pro-L 2 always uses gated measurements because it is a more robust way to measure loudness.

- To use Pro-L 2 in **EBU mode** (as part of the EBU R128 standard) you need to 1) set the Loudness Meter Target to "-23 (EBU)"; 2) enable True Peak Limiting and True Peak Metering and 3) set the Output Level to -1 dBTP. To comply with **ATSC A/85**, do the same but choose a target value of -24 LUFS and an Output Level of -2 dBTP.

- We recommend to combine integrated loudness metering with the **Infinite display mode** because this allows you to see the loudness curve change over time during the entire length of the incoming audio.

- You might sometimes see **LKFS** instead of LUFS when reading about loudness and metering. The LKFS unit was originally described for the first ITU-R BS.1770-1 specification. The EBU R128 specification introduced a slightly different implementation, and called it LUFS, which was later copied by ITU and incorporated in the BS.1770-2 standard. Since then, the two are essentially the same and can be interchanged.

---

**Next:** [Oversampling](#)

**See Also**

- [Overview](#)
- [Metering](#)
Oversampling

The limiting algorithm often needs to make very quick changes to the audio in order to remove peaks while preserving transparency and apparent volume. These sudden changes can introduce aliasing, which causes distortion and generally reduces the quality of the audio signal. Oversampling is a way to reduce that aliasing by running the internal limiting process at a higher sample rate that is a multiple of the host’s sample rate.

"When do I need to turn on oversampling?"

You need it more when the limiting process operates faster (using short lookahead times), and when limiting more heavily, both leading to a higher level of aliasing. Aliasing has the effect of adding spurious non-musical frequencies to the audible signal which degrades the audio quality. In addition, aliasing causes higher inter-sample peaks and these can cause distortion later on, for example during D/A conversion or conversion to MP3. There are only two small drawbacks to oversampling: it increases CPU usage, and it can introduce a very slight pre-ring due to the phase-linear filtering that is needed. Generally this effect is so small that it's inaudible, but it's good to be aware of this and not blindly assume that oversampling is always better.

"Which oversampling factor do I choose?"

We recommend 4x or possibly 8x oversampling for normal use as this will already drastically reduce aliasing and not cause extreme CPU usage. The 16x and 32x options may result in even higher audio quality, but for most systems this is simply too taxing to run in real-time especially if there are also other plug-ins in the session. You could use these options when doing offline rendering though.

Using true peak limiting and oversampling

If True Peak Limiting is enabled, FabFilter Pro-L 2 ensures that the true peaks in the output will not exceed the ceiling level set by the Output Level parameter in the bottom bar. However, if oversampling is off, more inter-sample peaks will be generated so the limiter has to do more work to keep them under the output level ceiling. Turning oversampling on (e.g. with the 4x option) will reduce the inter-sample peaks which allows the limiter to increase the overall output level and apparent loudness. In short, we highly recommend to use oversampling in combination with true peak limiting to get the best results.

Notes

- In Pro-L version 1, enabling oversampling could generate output levels that were slightly higher than the ceiling set by the Output Level parameter in the bottom bar. In Pro-L 2, we've improved the algorithm to ensure that this no longer happens. The actual output level now always respects the ceiling that was set, either measured in sample levels or true peak levels, depending on whether True Peak Limiting is enabled. Simply put, you no longer have to worry about this!

Next: Dithering and noise shaping

See Also
Overview
Recommended workflow
Dithering and noise shaping

In modern music production, most people are used to working with 24-bit audio to preserve as much resolution and precision as possible. Plug-ins usually work with 32-bit or 64-bit floating-point sample values. However, the audio that finally ends up on a normal CD only uses 16 bits of resolution. This means that at some point, the bit depth has to be reduced to suit the final medium.

The simplest way to reduce the bit depth of an audio signal, is to just truncate the least significant bits of every sample. However, this causes quantization distortion (in the form of unwanted harmonics) in the resulting audio. The best way to avoid this distortion, is by adding a tiny bit of white noise to the audio signal before truncating any bits. This eliminates the nasty quantization distortion at the cost of a slightly higher noise level in the final audio. This is called dithering.

To make the effect of applying dithering noise less audible in the final audio (in other words: to improve the signal-to-noise ratio), we can filter the noise introduced by the dithering process. That way, we don't end up with plain white noise (having a flat spectrum), but with noise that is less audible at frequencies where the human ear is most sensitive.

Dithering in FabFilter Pro-L 2

In the bottom bar of FabFilter Pro-L 2's interface, you'll find the dither settings panel. With two simple controls, you can specify your preferred dithering and noise shaping settings:

- The **Dither** setting specifies the desired bit depth of the resulting audio. You can choose to dither/quantize to 24, 22, 20, 18 and 16 bits. Of course, if you don't want any dithering, quantization (or noise shaping) to occur, just choose 'Off'.
- The **Noise Shaping** setting lets you choose between various noise shaping algorithms:
  - The **Basic** setting lowers the overall noise floor a few dB, at the cost of increasing noise levels for frequencies above 6 kHz.
  - With the **Optimized** setting, the effect is more extreme; you'll get an even lower overall noise level, but noise frequencies above 10 kHz are boosted more extremely.
  - **Weighted** noise shaping will transform the noise spectrum according to the ear's sensitivity to certain frequencies at low listening levels. Theoretically, this results in the lowest audible noise. This noise shaping setting is designed to be used at 44.1 kHz. It still works at other sample rates, but the frequency spectrum of the resulting noise isn't optimal anymore.

Note that the Dither button in the bottom bar will show the current target bit depth, plus an additional letter that indicates the chosen Noise Shaping setting, e.g. "20 Bits (W)".

Myths and facts

Theoretically, dithering the best way to retain as much resolution as possible when quantizing your audio. However, in the real world, dithering often has little to no audible effect. Here are a few things to keep in mind:

- Although loudness normalization is becoming more and more common, much of today's music is still mastered at quite loud (if not ridiculously loud) average levels, leaving very little dynamics in the final result. This already masks the small level of distortion due to quantization, so dithering probably won't have any audible effect.
- A lot of audio recordings already have a relatively high noise floor, due to the use of microphones, amplifiers, analog outboard, mixing consoles etc. In that case, dithering will have no beneficial effect at all; it will just increase the existing noise floor.
- Dithering should only be used as the final stage of audio processing/mastering. With any further processing, like gain changes, applying effects, or converting to yet another bit depth, the effects of dithering will be lost. If your host offers a post-gain effect insert slot on the master channel, use this slot for FabFilter Pro-L 2 when dithering is enabled.
- Dithering more than once doesn't make any sense. It will just increase the overall noise level in
your audio.

- When mastering for lossy formats as AAC/MP3, dithering doesn't make much sense. These formats don't have a fixed bit depth, and are usually created from a 24-bit input master anyway.

So when should you use Pro-L 2's dithering? The rule of thumb would be: when you use FabFilter Pro-L 2 in the final stage of mastering (for CD), handling audio with a very low noise floor of itself, and the end result is still fairly dynamic. But the most important advice of all is... use your ears!

**Notes**

- The white noise used for dithering in FabFilter Pro-L 2 is the industry-standard TPDF noise, 2-bit peak-to-peak.
- To read more on dithering, see [Dithering](#) and [Noise shaping](#) on Wikipedia.

---

Next: Input and output options

See Also

Overview

Recommended workflow
**Input and output options**

At the righthand side of the bottom bar in the interface, FabFilter Pro-L 2 has a Bypass button and an Output Level button that opens a panel with a large Output Level knob and various input and output options.

The **Output Level** knob plays an important role: it sets the desired maximum output level for the limiter. It seems natural to set it to 0.0 dB: you want the output to be as loud as possible, right? Not so fast.

Due to its ultra-fast behavior, the limiting process can generate **inter-sample peaks**, also known as **true peaks**: while none of the outgoing sample values are higher than 0 dBFS, the analog wave form that will be constructed out of the samples by the D/A converter can actually exceed this by several dB. Actually, any conversion that reinterprets the wave form, especially AAC/MP3 conversion, can expose inter-sample peaks. This will lead to unpredictable clipping and therefore possibly audible distortion.

"How bad is clipping caused by true peak?"

This is very hard to tell: it depends on many things, such as the quality of the D/A converter or AAC/MP3 conversion process and the character of the music. Many professionally mastered albums contain inter-sample clipping and this doesn’t have to be a problem. The main effect is that the music may suffer from slight distortion when played by low-quality D/A converters, or when converted to AAC/MP3 format.

"So what do you recommend?"

We recommend to turn on **True Peak Metering** to visualize the inter-sample peaks so you are at least aware of them. If the true peaks exceed your desired maximum output ceiling, you can either dial back the Output Level knob to accommodate for the true peak overshoot, or simply enable **True Peak Limiting** so that true peaks will never exceed the current Output Level (then showing as "dBTP" instead of the normal "dB").

The final Output Level ceiling you choose, depends on the metering standard you need to comply with and/or the medium you are mastering for. Theoretically, you could leave it at 0.0 dBTP with True Peak Limiting enabled, but commonly used metering standards like EBU R128 or ATSC A/85 require a specific maximum dB True Peak level (-1.0 dBTP and -2.0 dBTP respectively), just like popular streaming services as Spotify and Youtube (-1.0 dBTP). When mastering for CD or iTunes, you’re safe with -0.1 dBTP. Note that metering standards and requirements tend to change once in a while, so it’s always wise to stay updated about the current developments.

Instead of letting the True Peak Limiting process deal with remaining true peaks in the output, it’s even better to prevent high true peak overshoot in the first place. There are two ways to accomplish that: turning on **oversampling**, and slightly increasing the **Lookahead setting** in the Advanced panel. In most cases, choosing 4x oversampling in combination with a minimum lookahead time of 0.1 ms, keeps the true peaks within a range of 0.1 dB.

Right under the Output Level knob, there are four small option buttons:

- **The Filter DC Offset** button enables gentle DC offset filtering, which removes a possible DC bias in the input signal. This might have been introduced by earlier asymmetrical wave form processing or saturation. In case the input contains a DC offset, enabling this option avoids unnecessary and asymmetrical limiting of the signal.

- **The Side Chain Triggering** button routes the external side chain to feed the detection path of the limiting process, instead of the normal input of the plug-in. This can be very useful for stem mastering, when you need to deliver individual stems that have been processed with the exact same limiting as the original master. To achieve this, use Pro-L 2 on the stem channel, while feeding the original (unmastered, unlimited) master to its side chain input.

- **Enabling the Unity Gain** button automatically sets the Output Level to the inverse of the current Gain, so you can listen to the effect of limiting in relation to the input signal. This makes it much easier to determine the correct limiting settings and target gain, without getting distracted by the increasing loudness which always makes everything appear to sound better. When enabled, a yellow light glows at the top of the button and the output level meters will turn yellow to reflect this
state.

- If enabled, the **Audition Limiting** option subtracts the processed output from the input audio to audition the 'delta' signal: the actual gain reduction that is being applied. This can give a good indication of when and how much limiting is going on.

You can bypass the entire plug-in with the **Global Bypass** toggle button to the left of the output level button. While most hosts already provide the ability to bypass plug-ins, our internal global bypass feature is guaranteed to correctly compensate the latency of the plug-in and it also applies soft bypassing to avoid clicks. While the plug-in is bypassed, the display dims and a red light glows at the top of the bypass button itself.

**Notes**

- When loading presets, enable the **Lock Output** option next to the presets button to preserve the current gain and output settings. All factory presets were saved with a default output level of 0.0 dB.

- You can directly adjust the output level ceiling by clicking and dragging the output button vertically, so there is no need to click it first to view the output knobs. You can also double-click the output button to directly enter a value using the keyboard.

- The resize button at the right bottom of the interface lets you change the interface size from Compact to Large. See [Full Screen mode and resizing](#).

---

**Next:** [Surround and Dolby Atmos](#)

**See Also**

- [Overview](#)
- [Recommended workflow](#)
Surround and Dolby Atmos

FabFilter Pro-L 2 supports all important surround/immersive audio formats, up to 9.1.6 Dolby Atmos (depending on the DAW and plug-in format). When you add Pro-L 2 to a surround channel, the interface automatically adapts itself to the used multi-channel format. The output level meter will show all channels, with appropriate labels to identify them.

In addition, the Channel Linking section in the Advanced controls panel will have additional surround functionality.

Channel linking

When using Pro-L 2 on a surround channel, the Channel Linking section in the Advanced controls will offer a different, more extensive functionality: the Transients and Release knobs have an extra range (from "100% Stereo" to "100% All"), and additional C and LFE buttons are available.

In the first half of the range (from "0% Stereo" to "100% Stereo"), the Transient and Release link knobs work the same as in the stereo version of the plug-in: it controls the amount of linking between L and R channels (e.g. L/R, Ls/Rs, Lc/Rc or Lts/Rts). However, every stereo pair's linking is still independent of the other stereo pairs.

In the second half of the range (from "100% Stereo, 0% All" to "100% Stereo, 100% All"), all channels will interpolate to full all-channel linking, where every channel triggers on the same signal: the maximum of all channels.

With the C button enabled, the center channels (C, Cs) will be included in the linking of their associated...
L/R stereo pair, i.e. C is linked to L/R and Cs to Ls/Rs. When leaving it disabled (which it is by default), the center channels will always stay unlinked and operate fully independent from all other channels.

With the LFE button enabled, the LFE channel will be included in the all-channel linking in the second half of the range. When leaving it disabled (default), the LFE channel will always stay unlinked and operate fully independent from other channels.

Next: Full Screen mode and resizing

See Also
Overview
Full Screen mode and resizing

With just a click of the Full Screen button at the top-right corner in the interface, FabFilter Pro-L 2 will fill up the whole computer screen so you can get the most out of the level display and make ultra-precise gain adjustments.

To exit Full Screen mode, just press Escape or click the Full Screen button again.

Resizing

In addition to Full Screen mode, you can also customize the normal interface size using the Resize button at the right of the bottom bar. You can choose between Compact, Small, Medium or Large. Once you have selected a size, it will automatically become the default size for new plug-in instances.

Compact view

Some people like to judge their limiting by ear only. For that purpose, FabFilter Pro-L 2 offers a 'Compact' view mode. To switch to Compact mode, click the resize button in the bottom-right corner of the interface and click Compact in the menu that appears.

The Compact view doesn’t offer the real-time level display, but its level meters have more detail than the Normal view and it offers a large Output knob.
In Compact view, you can adjust the gain and the output level also by clicking and dragging on the level readouts below the Gain and Output knobs. Like with any knob, double-click here to type a value directly.

**Tips**
- When using the VST3 plug-in, you can resize the plug-in interface by just dragging the window edges to any size you like. Of course you can always go back to one of the predefined sizes with the resize button.
- The Medium and Large interface options will be greyed out in the Resize button menu if the current display is too small to support them.

*Next: [MIDI Learn](#)*

*See Also*
* [Overview](#)
MIDI Learn

Controlling FabFilter Pro-L 2's parameters directly with MIDI is very easy using the MIDI Learn feature. With MIDI Learn, you can associate any MIDI controller with any parameter.

Click the MIDI Learn button in the bottom bar to enter MIDI Learn mode. The interface dims and the parameters that can be controlled are highlighted. Each parameter has a small text balloon that displays the associated controller number. Now do the following to associate a controller number with a parameter:

1. Touch the control of the desired parameter in the interface that you wish to control. A red square will mark the chosen parameter.

2. Adjust the slider or knob on your MIDI keyboard or MIDI controller that you want to associate with that parameter.

That's it! The parameter will now be controlled with the MIDI controller. You can now go back to step 1 to associate a different parameter. Note that there is no warning when you associate a different knob with a controller number that is already used. It will just be replaced.

To exit MIDI Learn mode, click the MIDI Learn button again, or click Close at the top of the interface.

Click the small menu drop-down button next to the MIDI Learn button to access the MIDI Learn menu:

- **Enable MIDI**
  This globally turns MIDI control of parameters on or off: useful in hosts that automatically send all MIDI events on a track to all effect plug-ins associated with that track as well.

- **Clear**
  This submenu shows all parameter associations and lets you delete individual associations or clear all associations in one step.

- **Revert**
  Reverts to the last saved MIDI mapping (or the state when the plug-in was started).

- **Save**
  Saves the current MIDI mapping so Revert will go back to this state. The current mapping is automatically saved when closing the plug-in.

Routing MIDI to effect plug-ins

For MIDI Learn to work properly, the plug-in need to actually receive MIDI of course. Depending on your host, it can be quite difficult to route MIDI data to effect plug-ins. Here's how to do it in the most important hosts:

- **Pro Tools**
  Create a new MIDI track. From the MIDI input drop down menu, choose your MIDI device (if not already selected) and from the MIDI output drop down menu, choose FabFilter Pro-L 2 -> channel 1.
for the instance you would like to control.

- **Logic Pro**
  Instead of adding FabFilter Pro-L 2 to one of the insert slots, create a new **Instrument Track**, and click on the Instrument slot. Then choose **AU MIDI-controlled Effects > FabFilter > Pro-L 2**. Now, the plug-in receives MIDI. To get audio into the plug-in, click the 'Side Chain' drop down menu in Logic's plug-in header and choose the actual input track. Next, you can mute that original track, so you only hear the audio through the plug-in. The only downside is that plug-ins with an external side-chain cannot use it anymore.

- **Ableton Live**
  First of all, create a new **MIDI track**. From the 'MIDI from' drop down menu, choose your MIDI device (if not already selected). Then, in the 'MIDI to' drop down menu, choose the Audio track that has FabFilter Pro-L 2 on it. Note: only the first plug-in on any track can receive MIDI.

- **Cubase**
  Simply create a new **MIDI track** and set its output to the Pro-L 2 instance you would like to control via MIDI.

Next: Undo, redo, A/B switch

See Also
Overview
Undo, redo, A/B switch

The Undo and Redo buttons at the top of the FabFilter Pro-L 2 interface enable you to easily undo changes you made to the plug-in. With the A/B feature, you can quickly switch between two different states of the plug-in.

- The **Undo** button at the left will undo the last change. Every change to the plug-in (such as dragging a knob or selecting a new preset) creates a new state in the undo history. The Undo button steps back through the history to restore the previous states of the plug-in.

- The **Redo** button cancels the last undo command. It steps forward through the history until you are back at the most recent plug-in state.

- The **A/B** button switches from A to B and back. Before switching, the current state of the plug-in is saved, so if you click this button twice, you are back at the first state. The button highlights the currently selected state (A or B). In the example above, the A state is active.

- The **Copy** button copies the active state to the inactive state. This marks the current state of the plug-in and allows you to go back to it easily with the A/B button. After clicking Copy, the button disables itself to show that both states are equal, so there is nothing to copy anymore.

**Notes**

- If the plug-in parameters are changed without using the plug-in interface, for example with MIDI or automation, no new undo states are recorded.

- The Undo and Redo buttons will disable themselves if there is nothing to undo or redo.

Next: [Using on iOS](#)

See Also

[Overview](#)
Loading presets

FabFilter Pro-L 2 comes with a selection of excellent factory presets that provide ready-to-go limiting setups for almost all scenarios and types of audio.

- To load a preset, click the preset button. The presets menu will appear with all available presets. Click a menu item to load that preset. The currently selected preset is highlighted with check marks.
- To explore the presets one by one, click on the little arrow buttons to the left and right of the main preset button. This will load the previous or next preset in the menu.

The preset button shows the name of the current preset. If you have changed the preset by adjusting one or more parameters, the name is dimmed to indicate that this is not the original preset anymore.

Tips

- The Default Setting preset is loaded automatically when FabFilter Pro-L 2 is started. To change the default settings, simply overwrite this preset by clicking Options > Save As Default in the presets menu.
- To open a preset outside the presets folder, click Options > Open Other Preset. This might be useful if someone sends you a preset by email, for example.
- If somehow the factory presets are lost or not installed properly, click Options > Restore Factory Presets in the preset menu to restore them.

MIDI Program Change and Bank Select

Loading a presets can also be done via MIDI, using Bank Select and Program Change messages. Click Options > Enable MIDI Program Changes in the preset menu to enable or disable this feature. When enabled, the corresponding bank/program numbers are shown in front of the preset name (for example: (0/65) My Preset). This means that you can load that preset by first sending a Bank Select message to select bank 0 and then sending a Program Change message to select program 65.

Important: All the presets in your preset folder are numbered automatically, starting with bank 0 and program 0. This way, you are able to access any of the presets via MIDI. However, this also means that when you add new presets to the menu, bank/program numbers of other presets might change. Be aware of this when recording program changes in a session! We recommend to create a dedicated folder in your presets folder for your program changes, and name it with two leading underscores (e.g. "__Programs") to ensure it's the first folder in your preset collection and the presets in this folder start with bank 0 and program 0.

Next: Saving presets

See Also

Using on iOS
Overview
Recommended workflow
**Saving presets**

You can easily extend the included presets with new settings to build your own library of presets for FabFilter Pro-L 2 that you can reuse in various projects. This is also a good way to copy settings across multiple instances of FabFilter Pro-L 2 in a session.

To save the current setting as a preset, click the preset button, and then click *Save As*. A standard Save dialog will appear. Type a name for the new preset and click *Save* to finish.

In the Save dialog, you can also rename and delete existing presets and create a new folder to store presets in. New folders will show up as new categories in the preset menu. (On macOS, this should be done with the Finder.)

See [How presets are stored](#) to determine the preset folder location and learn more about factory presets.

**See Also**

- [Loading presets](#)
- [Overview](#)

---

*Next:* [How presets are stored](#)
How presets are stored

Presets for FabFilter Pro-L 2 are stored in separate files with the .ffp extension (for FabFilter Preset). All presets reside in subfolders in the main preset folder. The subfolders will show up as separate categories in the preset menu. You can also further divide the subfolders into categories.

You can manage the preset files just like other files on your computer. The easiest way to do this is in the Save dialog that appears if you are saving a preset. The preset menu will automatically reload itself with the changes when the dialog is closed.

Furthermore it is very easy to share your newly created presets with other users since FabFilter presets use the same file format on both Windows and macOS.

The default location of the main preset folder is Documents/FabFilter/Presets/Pro-L 2 on both Windows and macOS. To change this location, first copy all presets to the desired new location, and then click Options > Change Preset Folder in the preset menu and select the new folder.

Note: previously on macOS, presets were stored in ~/Library/Audio/Presets/FabFilter/FabFilter Pro-L 2. To determine the current location of the presets folder, click Options > Change Preset Folder in the preset menu.

Restoring factory presets

If you have accidentally lost the factory presets, you can easily restore them by clicking Options > Restore Factory Presets in the preset menu. This will install all factory presets again.

Next: Purchasing FabFilter Pro-L 2

See Also
Saving presets
Overview
Purchasing FabFilter Pro-L 2

Once you have downloaded and installed the evaluation copy of FabFilter Pro-L 2, you may evaluate it during 30 days. Every time you start the plug-in, you will see the following dialog:

![FabFilter Pro-L 2 Evaluation Dialog](image)

While there are still days left, you can click **Evaluate** to start working with the plugin. If you want to keep using FabFilter Pro-L 2 after the evaluation period, you must buy a copy in the online FabFilter Shop by clicking the **Buy Now** button in the evaluation dialog.

- Go to the FabFilter Shop and purchase FabFilter Pro-L 2 now

We accept a wide range of payment methods, like credit cards, PayPal, wire transfer and iDeal. The FabFilter Shop uses secure connections and encryption: therefore your personal information is completely safe.

Within a few minutes after you have purchased your copy, you will receive an email containing your personal license key. You use this license key to turn the evaluation copy into a fully registered version without the evaluation dialog and the 30-day trial restriction. In addition, we will automatically create a FabFilter account for you (if you don't have one already). Here, you can access all your license keys at any time.

**Note**: If the evaluation period has expired but you didn't have the chance to properly evaluate the plug-in, you can request a new evaluation period by contacting us at info@fabfilter.com.

Next: Entering your license key

See Also
- Support
- License agreement
Entering your license key

After you have purchased FabFilter Pro-L 2 in the online FabFilter Shop, you will immediately receive an e-mail containing your personal license key. This license key will turn the evaluation version into a fully registered plug-in.

- Start FabFilter Pro-L 2 and click Enter License in the evaluation dialog, or click Enter License on the Help menu if the plug-in is already running.
- Copy the license information from the email you have received and paste it into the text field. Make sure that you are copying the entire license key including the Product and Licensee lines! If you are not sure what text to copy, just copy and paste the whole e-mail.

After you have entered your license information, you will need to restart the plug-in host, so make sure you save your settings if needed. From now on, you will be able to use FabFilter Pro-L 2 for an unlimited period of time with full support via email.

Tips
- After your purchase, you can always retrieve your license key again by logging into your personal FabFilter account. Here you can also keep track of all your orders and take advantage of great discounts when buying other FabFilter plug-ins.
- To deauthorize your license key and remove it from the computer, click Deauthorize on the Help menu. If you temporarily needed to install your license on another computer, or if you have transferred your license to someone else, this is the way to deinstall your personal license key safely.

Next: Support
See Also
Purchasing FabFilter Pro-L 2
Support
License agreement
Support
If you need help with problems or questions, and the help file does not provide an answer, please visit the support pages on our web site.

- Go to FabFilter Support

From here, you have direct access to the customer support forum, very useful tutorial videos for all FabFilter plug-ins, online and PDF versions of all our help files, and a section with extra downloads (such as presets, controller templates, older plug-in versions).

For sales-related questions and technical support, you can also contact FabFilter directly at info@fabfilter.com.

Reporting a bug
If you have encountered a bug in FabFilter Pro-L 2, first of all make sure that you are using the latest version of the plug-in, which you can find at www.fabfilter.com/download. You can easily check the version of FabFilter Pro-L 2 that you are using by clicking Help > About in the plug-in interface. If the bug is still present in the latest version, please send us an e-mail at info@fabfilter.com and include as much technical information as possible: operation system and version, host software and version, steps to reproduce the bug, etc. Thanks in advance!

Next: Upgrading to Pro-L 2

See Also
Overview
About FabFilter
Upgrading to Pro-L 2

Upgrading from Pro-L version 1 to the new Pro-L 2 is safe and easy: installing Pro-L 2 will not replace or delete the previous Pro-L 1 plug-in. Both versions will co-exist and can both be used at the same time. This ensures that you can open old songs that use Pro-L 1 without problems!

Pro-L 1 presets

All presets created with Pro-L 1 can be loaded in Pro-L 2. If you upgraded from Pro-L 1 to the new version, your original Pro-L 1 presets will be accessible via the V1 Preset Folder item in the preset menu. See also Loading presets.

Replacing a Pro-L 1 instance by Pro-L 2

If you are working on a song and want to replace a Pro-L 1 instance with the new Pro-L 2, we advise you to do the following:

- First, save the current setting of the Pro-L 1 instance as a FabFilter preset in the Pro-L 1 preset folder.
- Then, remove the Pro-L 1 instance and add Pro-L 2 in its place.
- Finally, load the V1 preset that you just created into Pro-L 2 via the V1 Preset Folder submenu in the preset menu.

Automation

Because the feature set of Pro-L 2 has changed fundamentally, any automation data that has been written by a Pro-L 1 instance cannot be read correctly by Pro-L 2.

Next: Manual installation

See Also

Overview
Support
Manual installation

When installing FabFilter Pro-L 2, the installation program will try to copy the plug-in into the appropriate plug-ins folders, and in most cases your host will recognize FabFilter Pro-L 2 automatically. Otherwise, please follow these instructions:

Windows

On Windows, most hosts have their own VST plug-ins folder. So if you are using Windows and your host does not recognize FabFilter Pro-L 2, you need to locate the proper plug-ins folder for your host first (it is usually shown in the Preferences or similar dialog). Then, copy the file FabFilter Pro-L 2.dll from C:\Program Files\FabFilter\Pro-L 2 (or C:\Program Files (x86)\FabFilter\Pro-L 2 if you are using a 32-bit host on 64-bit Windows) to the plug-ins folder that you have found and restart the host so it can reload all its plug-ins. For the AAX version of Pro-L 2, copy the FabFilter Pro-L 2.aaxplugin folder to the common Pro Tools AAX plug-in folder on your computer.

You can simply uninstall plug-ins or bundles via the Control Panel.

macOS

On macOS, plug-ins are installed in the standard plug-in folders in the system Library folder. These are the only possible correct locations:

- Audio Units: /Library/Audio/Plug-Ins/Components
- VST/VST3: /Library/Audio/Plug-Ins/VST and /Library/Audio/Plug-Ins/VST3
- AAX: /Library/Application Support/Avid/Audio/Plug-Ins

Note: AU and VST/VST3 plug-ins may also be placed in the user's Library folders under /Users/<username>/Library/Audio/Plug-Ins.

To uninstall the plug-ins from your Mac, you can just delete the specific FabFilter plug-in files at the above locations. Finally, if you really want to delete all data written by our plug-ins, you can remove the following folders/files from the user Library folder as well:

- /Users/<username>/Library/Audio/Presets/FabFilter/FabFilter Pro-L 2
- /Users/<username>/Library/Application Support/FabFilter/Pro-L 2
- /Users/<username>/Library/Preferences/com.fabfilter.Pro-L.2.plist

Note: Since OS X 10.7 (Lion), the system and user Library folders are marked as hidden by default. To make them visible again in Finder, open Terminal (found in /Applications/Utilities) and enter the following commands:

    chflags nohidden /Library
    chflags nohidden ~/Library

If you still have problems, contact FabFilter Support.

Next: VST plug-in versions

See Also
Quick start
Support
VST plug-in versions

FabFilter Pro-L 2 is available in both VST 2 and VST 3 formats. They can be installed and used both at the same time. The VST 3 format offers easy side-chaining, free interface resizing, and is more CPU-friendly in some cases, but it can only be used by hosts that support it, for example recent versions of Cubase, Studio One or FL Studio. The VST 2 format is compatible with a larger variety of hosts.

Both the VST 2 and VST 3 versions of the plug-in automatically adapt themselves to the channel layout of the track they are inserted on (mono/stereo and surround).

Next: External side chaining

See Also
Quick start
Manual installation
External side chaining

FabFilter Pro-L 2 offers the possibility of feeding an external signal to its side chain, so that you can make it trigger on a different signal than the audio it is actually processing. Feeding a signal to a plug-in's side-chain inputs works slightly different in various hosts. This topic describes the procedure for some of the most popular hosts around: Pro Tools, Studio One, Ableton Live, Logic Pro and Cubase.

To explain how it works, we use a scenario with two tracks. The first one contains the audio that we want to process with Pro-L 2, which we'll call the main track from now. The second track contains the audio that we want to route to Pro-L 2's external side-chain input and use as trigger signal. We'll call this track the side chain track.

With a limiter like FabFilter Pro-L 2 using external triggering is mainly useful for stem mastering, where you want to print separate stems with the limiting/gain reduction as applied to the full master. See Output options for more information.

Pro Tools

- Open Pro Tools and start a new empty session.
- Create two audio tracks that we'll use as main track and side chain track. Add audio files to both track.
- Open the Mix window to display the tracks with their Insert slots and Sends slots.
- In the first 'Sends' slot of the side chain track, choose 'Bus 1'. The track view for Bus 1 will open: set its level slider to 0.0 dB so the bus actually produces audio!
- In the first 'Inserts' slot of the main track, choose Dynamics > FabFilter Pro-L 2.
- Open FabFilter Pro-L 2's interface and set Side Chain to Ext.
- Now, in the 'Key Input' menu of the plug-in interface (just above the FabFilter logo), choose bus > Bus 1 instead of the default 'no key input'. Now, the audio from the side chain track is routed to Pro-L 2's external side chain input via Bus 1.

Studio One

- Open Studio One and choose 'Create a new song'.
- Add two audio tracks (via Track > Add Tracks...) that we'll use as main track and side chain track.
- Add audio files on both the main track and the side chain track. You can simply drag audio files from a Finder/Explorer window onto a track.
- Access the mix window via "Mix" in Studio One's bottom right corner.
- Insert FabFilter Pro-L 2 on your main track via the '+' button next to the Insert tab.
- Open FabFilter Pro-L 2's interface and set Side Chain to Ext.
- On the side chain track, select Sends > Sidechains > FabFilter Pro-L 2.
**Ableton Live**

- Open Ableton Live and start with an empty arrangement. We'll use Track 1 as the side chain track and Track 2 as the main track.
- From the folder menu's on at the left top of Ableton Live's interface, drag different audio clips to the first empty slots of Track 1 and Track 2.
- From the VST (or Audio Units) plug-in menu, also at the left top of Ableton Live's interface, drag FabFilter Pro-L 2 onto Track 2, the main track.
- In the small device interface for Pro-L 2 in the bottom Effects section, choose 'Track 1' from the 'Sidechain' drop down menu.
- Open FabFilter Pro-L 2's interface and set Side Chain to **Ext**.
- **Note:** In earlier versions of Ableton Live (< 10.1), setting up sidechaining worked differently, which is described [here](#).

**Logic Pro**

- Open Logic Pro and create a new empty project via File > New...
- Add two audio tracks (via Track > New...) that we'll use as main track and side chain track.
- Add audio files on both the main track and the side chain track. You can simply drag audio files from a Finder/Explorer window onto a track.
- Select the main track and add Pro-L 2 in the first Insert effect slot.
- Open FabFilter Pro-L 2's interface and set Side Chain to **Ext**.
- In the right top corner of the plug-in interface header, in the 'Side Chain' menu, choose the side chain track. Now, the signal from the side chain track is sent to FabFilter Pro-L 2's external side-chain input.
Cubase

- Open Cubase and create a new empty project.
- Add two audio tracks that we'll use as main track and side chain track.
- Add audio files on both the main track and the side chain track. You can simply drag audio files from a Finder/Explorer window onto a track.
- Open the Mixer. In the main track, click on an empty insert slot and select the VST 3 version of FabFilter Pro-L 2 in the Dynamics menu (note the VST 3 icon which looks like ///).
- Open FabFilter Pro-L 2's interface and set Side Chain to Ext.
- In the plug-in header, click on the Activate Side-Chain button (right of the R/W buttons) to enable the external side chain in Cubase.
- At the top of the Mixer, set the output for the side chain track to the side-chain input of FabFilter Pro-L 2.

Next: License agreement

See Also
Quick start
Manual installation
FabFilter Software License Agreement

This license agreement concerns and describes your rights and the conditions upon which you may use the FabFilter software you selected. We advise you to read this entire agreement. By accepting this agreement or by using FabFilter software, you agree to all of these terms. If you do not accept and comply with these terms, you may not use the FabFilter software or its features.

Applicability

This license agreement applies to all the FabFilter software, plug-ins and programs you may use during the Evaluation period, and/or thereafter subject to an acquired license key to certain FabFilter software of any version, including any and all upgrades, supplements or services, unless other terms come with such versions, upgrades or supplements.

Licenses

The software will be licensed to the Customer, not sold. With the FabFilter license key, you will be granted after full payment the right in perpetuity (meaning that the license agreement shall not automatically expire) to install, run and use the software concerned under certain conditions. These conditions vary subject to the license you acquired. FabFilter distinguishes the following licenses:

- **A Personal License** is a named license to the software concerned, granting access to the software on an unlimited number of Devices, as long the license is used by the designated person who acquired the FabFilter license key. Usage of the Personal license by someone else but the designated licensee is an infringement of the rights of FabFilter. The Customer should at all times protect its license key from theft and/or abuse.

- **A Site License** is a non-personal license to the FabFilter software concerned, acquired on the name of an institution or entity, who is the licensee. A Site License will grant access to the FabFilter software on a certain maximum number of designated Devices, as specified in the license key itself (e.g. "20 seats"). If the Site License is used on computers/servers for any form of automated processing, the licensee may not make any plug-in controls/parameters of the FabFilter software available to the end users of the FabFilter software, i.e. only "black box" processing is allowed.

These FabFilter licenses, whether a Personal or Site License, will give you access to certain FabFilter software of the specified major version. The license will include all future minor updates to the software (e.g. version 2.19 to version 2.20), which typically include bug fixes or small new features. The license will exclude any future new major versions of the products (e.g. version 1.x to version 2.x). To allow yourself access to such new major version of the software, a new FabFilter license to such major version must be acquired.

All FabFilter licenses, both Personal or Site License, give the Customer or end user the right to install and use the FabFilter software to the extent it has been developed and under the conditions herein. Any rights not explicitly granted to you, the Customer, remain with FabFilter, including but not limited to the right to alter, reverse engineer, reverse compile, take apart, or disassemble the FabFilter software or any of the files in the distribution.

A Bundle License is Personal or Site License for multiple FabFilter software products, which gives the Customer or end user the right to install and use the specific software products that the bundle (e.g. Total Bundle) contains at the moment of purchasing the Bundle License. Any software products or new major software versions added to the bundle after that date cannot be claimed as part of the prior acquired Bundle License. A Bundle License (if not Educational or NFR) can only be transferred as a whole, using a License Transfer.

An Upgrade License is a Personal or Site License for a new major version of FabFilter software. You may only use an Upgrade License if you have a license for the previous major version of the same FabFilter software.

**Educational (EDU) and NFR licenses**

A Personal or Site License can be marked as EDU (Educational) or NFR (Not For Resale), meaning the following:

- A Personal or Site License marked as Educational License is equal to the respective Personal or Site License, with the only exception that the Educational License may not be transferred to a third party.

- A Personal or Site License marked as NFR ("Not For Resale"), is typically intended for journalists that wish to review the FabFilter software. A License marked as NFR is equal to the respective Personal or Site License, with the only exception that the NFR License may not be transferred to a third party.

**Duration and Evaluation**

As specified in the specific terms per license, all licenses will be granted for perpetuity (meaning that the license agreement shall not automatically expire), as long as all conditions herein are respected.
The Evaluation period is a period of thirty (30) days commencing on the first day of using the software concerned and automatically expiring 30 days thereafter. After the Evaluation period has expired and no FabFilter license key has been acquired, the software will stop working and should be removed from your computer.

In addition to any and all such possibilities that FabFilter may have in accordance with the law, FabFilter may terminate without prior notice or warning in case of abuse of the FabFilter software as well as in case of (personal) bankruptcy.

Support
FabFilter shall give its reasonable commercial efforts to service any major version of any FabFilter software including email support. FabFilter is entitled to terminate support for any major version of any FabFilter software at any time at its sole discretion.

License Transfer
A Personal or Site License (not Educational or NFR) may be transferred to a third party. You will have to buy a License Transfer to activate the "transfer"-option in your FabFilter account. After this option has been activated you will be able to transfer your license to any third party.

Third Party Software
VST is a trademark of Steinberg Media Technologies GmbH. RTAS and AAX are trademarks of Avid Technology, inc. Audio Units is a trademark of Apple Computer, inc.

Applicable Law
This license agreement is governed by Dutch law. The courts of Amsterdam are authorized courts to rule on any dispute that may arise from this license agreement.

Disclaimer
TO THE MAXIMUM EXTENT PERMITTED BY LAW, FABFILTER, FREDERIK SLIJKERMAN AND FLORIS KLINKERT, AUTHORS OF THIS FABFILTER PRODUCT, SPECIFICALLY DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. FABFILTER, FREDERIK SLIJKERMAN AND FLORIS KLINKERT, DO NOT WARRANT THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT THE SOFTWARE WILL OPERATE ERROR-FREE OR UNINTERRUPTED. TO THE MAXIMUM EXTENT PERMITTED BY LAW, FABFILTER, FREDERIK SLIJKERMAN AND FLORIS KLINKERT, SHALL NOT BE LIABLE FOR ANY DAMAGE A FABFILTER PRODUCT MAY CAUSE OR DAMAGES THAT MAY ARISE OUT OF THE USE OF A FABFILTER PRODUCT OR INABILITY TO USE A FABFILTER PRODUCT, INCLUDING BUT NOT LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL OR OTHER DAMAGES. IN NO EVENT FABFILTER, FREDERIK SLIJKERMAN OR FLORIS KLINKERT WILL BE LIABLE FOR AN AMOUNT IN EXCESS OF TWO HUNDRED FIFTY EUROS (€ 250,00).

Next: Acknowledgements
See Also
Purchase FabFilter Pro-L 2
Support
Acknowledgements

For the development of FabFilter Pro-L 2's internal limiting algorithms, we worked closely together with Niklas Silen (AKA bManic). Niklas developed the Transparent, Dynamic and Modern limiting styles and was very influential in the general design of Pro-L version 1 and 2. His never fading enthusiasm and persistance is inspiring. Thanks!

Furthermore, of course we want to thank all our beta testers, helping us to fine-tune the limiter.

FabFilter Pro-L 2 comes with a selection of ready-made presets, most of which were created by external engineers:

- bManic
- Stephan Muesch (SM)
- Ricardo Sangiao (RS)

Visit the FabFilter sound designers page to read more about each sound designer.

Next: About FabFilter

See Also
Purchase FabFilter Pro-L 2
Support
About FabFilter
Beautiful sound. Fantastic workflow. These are the foundations of FabFilter. We create powerful audio plug-ins with superb sound quality and innovative interfaces.

A unique perspective
At FabFilter, we make the best possible tools for music production and audio processing. To achieve this, we continually rethink and challenge industry standards: we've never been afraid of reinventing the wheel. Considering every little detail, we tune our algorithms and interfaces until they sound perfect, look amazing and feel great to work with.

It's the sound that counts
Above everything else, you need superb sound quality. That's why we put a lot of effort into developing unique audio processing algorithms, ranging from our famous resonating filters to transparent high-end EQ and dynamics processing.

Innovative interfaces, great design
Every FabFilter plug-in has an easy-to-use, well-designed interface aimed at providing unsurpassed workflow. Our plug-ins focus on the task you're performing at that specific moment: they expose the features you need, when you need them. And because of our special attention to design, you'll be delighted every time you open a FabFilter plug-in.

Don't take our word for it
We always set the highest standard for sound quality, usability and design to make truly great products that raise the bar on what audio software can do. That's why we're very happy with the praise we've received from users and press alike:

"In the decade since the release of its first plug-in, One, FabFilter has made an indelible mark on the music production landscape." — Computer Music magazine

"While many other software developers are busy trying to model hardware, FabFilter is leaving them in the dust by being visionaries and reaching into the future. FabFilter stuff is just on another level." — Jeff Sanders

"FabFilter has an enviable reputation for making easy-to-use, powerful tools." — Music Tech magazine

FabFilter was founded in 2002 by Frederik Slijkerman and Floris Klinkert, and is based in Amsterdam, The Netherlands.

See Also
Support
FabFilter web site
