FabFilter User Forum

[Warning] Pro-C2 in Reaper

Hello guys,

This is something that took me two hours to find out.

I compared the Pro-C2 with another compressor and the Pro-C2 behaved strangely. I wanted to compress a Piano sound so I played the MIDI Piano in a Native Instrument plugin then the compressor. The C2 was always compressing as soon as there was sound, even a tiny one that was way below the threshold.

Well, after hours I figured it out, so I give the trick to you.

I'm using (the fantastic) Reaper. In Reaper, a track can contain anything. Thus, what happened is that MIDI orders I sent from my keyboard were also going through the NI Instrument and to the Pro-C2.

By default, the Pro-C2 is configured to react to MIDI and to compress. That was what happening: the same MIDI order was producing the note and activate the compression!

I have to disable the Pro-C2 MIDI handling in order to restore a normal behavior.

I would prefer that, by default, this was off.

Regards

Didier B.

Hi Didier,

Correct, some of our dynamics plug-ins like Pro-C 2 and Pro-DS see Midi notes as a 0dBFS side-chain input, which triggers the compressor. This is on by default. You can turn it off and save the settings as your default settings in the preset menu, so it will be off by default.

Cheers,

Ralph (FabFilter)

Thanks for your answer. I tested this and it works. The problem is that I would have to update every vendor preset in order to make this efficient (MIDI is enabled as soon as I change to a setting that is not overwritten). However, if I need this MIDI input, I have to pay attention again.

Can you, as a feature request for the next version, enable a global setting that allow to turn on/turn off/use preset for the MIDI sidechain.

Thanks

Didier B.

Hi Didier,

A fair point and we'll look into that for a future update.

Cheers,

Frederik (FabFilter)
Reply to this topic Go to the forum topic list