FabFilter User Forum

How to: Reauthorise FabFilter plugins

Hi there,

I use an application called Equaliser APO to adjust Windows sound with FabFilter EQ (Pro-Q 2 or Pro-Q 3). It works fine for 1 month with either of the EQs, then suddenly stops working.

Every time I open an application that uses Windows audio, there is absolutely no sound until I "fiddle" with the Pro-Q 2 or Pro-Q 3 band settings or disable/re-enable the plugin.

This isn't an issue with Equaliser APO as it works perfectly with Pro-Q 2 for exactly a 1 month period (I timed it), then suddenly stops working. Then I have to use Pro-Q 3 instead. This also works for exactly a 30 day period and then suddenly stops working in the same way.

Therefore, I presume it's a licencing issue with the plugin and nothing to do with the application itself (Yes, I did purchase these plugins and they're activated properly).

Furthermore, the application works perfectly with other FabFilter plugins when they're run inside of it, even after having issues with Pro-Q 2 and 3 stopping working after 1 month respectively. I tested FabFilter Saturn for 1 month and the exact same thing happened.

Is there any way I can "renew" the licences to these plugins? I've tried reinstalling them and this doesn't rectify the issue. The only workaround is if I reinstall an old system clone every two months after having used Pro-Q 2 and Pro-Q 3 until they both stop working, but this means I have to reinstall any recently installed software too.

I've also tried other applications such as "VB-Cable Virtual Audio Device". The exact same behaviour occurs. One month in, the plugin stops transmitting audio through them and I need to "fiddle" with an EQ band every single time I want to use an audio application that uses Windows audio.

Sorry for the long post. Hope it explains everything in enough detail.

Cheers, Jim.


Steps I've tried to resolve it:

1. Uninstall and reinstall Equaliser APO, including removing all registry entries during uninstall.
2. Uninstall and reinstall all FabFilter plugins after deauthorising them, including removing all registry entries during uninstall.
3. Restarting PC.
4. Copied the FabFilter Pro-Q 2 and 3 dlls to a new folder and tried to load them from there. No difference.
5. Uninstalled and reinstalled Windows 10 fresh. This solved the issue (for only 30 days like before).
6. Restored a previous Clone of Windows 10. This works for a few days, depending on how many days are left of the 30 days I have to use the plugin inside Equaliser APO. I kept having to restore the backup clone every 5 days to keep it working so I could listen to clients' tracks with the EQ compensation active.

Here's a log from Equaliser APO (not sure if it'll help to track down the issue):

2019-10-01 16:44:37.995 11064 01458140 (filters\VSTPluginFilter.cpp:52): The VST plugin C:\Program Files\FabFilter\Pro-Q 3\FabFilter Pro-Q 3.dll crashed during initialization.
2019-10-01 16:44:37.996 11064 01458140 (filters\VSTPluginFilter.cpp:108): The VST plugin C:\Program Files\FabFilter\Pro-Q 3\FabFilter Pro-Q 3.dll crashed while preparing for processing.

I'm guessing the "cpp:52" and "cpp:108" refers to C++ line numbers. I'll also post this on the Equaliser APO forum too. Maybe it's an issue with their application and nothing to do with 30-day lockout of unauthorised plugins.


Steps to replicate the issue:

1. Install Equaliser APO (or any other APO you wish to use)
2. Add any FabFilter plugin to the application
3. The plugin will become inactive after 30 days
4. Upon opening any application that uses Windows audio, no sound will be heard
5. Tweak any setting slightly in the FabFilter plugin on Equaliser APO - sound is restored
6. Close the audio application that's playing sound and reopen it. There will be no sound and the problem persists. You'll need to go to step 5 and repeat the cycle.

This happens only with FabFilter plugins. I've tried with others, but I cannot get the correct EQ shape to give accurate speaker compensation. I'd much prefer to use FabFilter Pro-Q 3.

Cheers, Jim.


Hi Jim,

This sounds very strange. The 30-day period exactly matches with our evaluation period, so it makes sense that this is somehow related. It's possible that APO runs our plugins such that they think they are not licensed, so they will work for 30 days and then just produce silence. What doesn't make sense is that they will start to produce sound again if you tweak a parameter. So that makes me think it might be an issue in the APO application.

Do you have a normal VST host application on your computer, like Ableton Live or Reaper? Can you check whether Pro-Q 3 works normally in that host?


Frederik (FabFilter)

Hi Frederik,

I use Cubase Pro 10.0.40 and all FabFilter plugins work perfectly in there without issue.

I've tried to find out how to contact the developer(s) of Equalizer APO but can't find any info on who to contact.

I'm currently using a workaround - setting each band individually using the integrated parametric EQ bands within Equalizer APO.

No worries if it's something you can't solve on your end.

Cheers, Jim.


I have the same exact problem... got anyway to fix it ? I bought a license just for this :(


Reply to this topic: