FabFilter User Forum

Pro-L2 latency

For some reason I'm getting massive latency (>65 ms) on the "Bus" algorithm in Logic (v10.3.3). As expected, switching to "Transparent" brings it down to 12 ms - which is still 50% more than the same setting in Pro-L1 (8 ms). It looks like the latency isn't being compensated for by the host which makes Pro-L2 useless on a bus or individual track, especially with the "Bus" algorithm. Is this normal or is it some limitation of the demo mode in Pro-L2? The eval period runs out in 5 days, I have a registered license of Pro-L1 though.


Hi Teenmeister,

The new algorithms in V2 indeed have a lot more latency, due to a different, more advanced design. However, any normal host should be easily capable of compensating for it.

If you need minimum latency, choose the Transparent algorithm and also disable True Peak Limiting in the bottom bar.

Floris (FabFilter)

Thanks Floris. TPL is disabled on the bus (Pro-L2 on the master bus takes care of this). I'll try some other things to bring down the latency. Theoretically, the issue could be related to the most recent version of Logic. I had plans to upgrade to Pro-L2 because of the new algorithms (that sound pretty good on the master bus...) but if I can't tame the latency somehow I'll stick to the bx_limiter / Pro-L1 combo for now.


For me also a huge latenz in Cubase. I use Pro-L2 in the master channel in modern mode without TPL. Not usable for composing. So I load the Pro-L1 but is not that for what I have made an update to Pro-L2.

So I hope for future that the algorythm will be optimized for less latenzy.


Hi Ueli,

For low latency, use the Transparent algorithm and disable TPL like Floris wrote. Then you'll get roughly the same latency as in Pro-L v1.


Frederik (FabFilter)
Reply to this topic Go to the forum topic list