FabFilter News

All plug-ins compatible with macOS High Sierra 10.13

Sep 26, 2017

We're happy to confirm that all FabFilter plug-ins, as currently available on www.fabfilter.com/download, are fully compatible with the latest macOS High Sierra 10.13.

Product details Back to list